diff options
author | Paul Kehrer <paul.l.kehrer@gmail.com> | 2014-01-20 15:05:27 -0600 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2014-01-20 15:05:27 -0600 |
commit | 81a68fc96d0845f5ee812665405276a935d05a79 (patch) | |
tree | 0478a737c0db71df5bee8f1b02d2a89713590867 /setup.py | |
parent | 74169660e47b760f82c0653b4210b3bc5d3bf46b (diff) | |
parent | 78456c71627d9234a4668ce2fb36e12525cae6b1 (diff) | |
download | cryptography-81a68fc96d0845f5ee812665405276a935d05a79.tar.gz cryptography-81a68fc96d0845f5ee812665405276a935d05a79.tar.bz2 cryptography-81a68fc96d0845f5ee812665405276a935d05a79.zip |
Merge branch 'master' into urandom-engine
* master: (58 commits)
Moar backtick.
Add to changelog.
move some dashes around :)
experiment to disable duplicate cc test runs on osx and speed up travis
Remove register_cipher_adapter from the interface and the documentation.
expand tox backend example
On OS X at build time compile the CC bindings
remove an extraneous linefeed
reformat bindings and remove GCM for the moment
add cipher bindings for CommonCrypto
doc updates
hmac support for commoncrypto
added versionadded
changelog to note addition of commoncrypto backend with hash support
fix docs
doc updates
update docs for name attribute
fix copy mistake in docs
increase indent and note the value of the attribute in the docs
move HashMethods to top level
...
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 13 |
1 files changed, 11 insertions, 2 deletions
@@ -43,14 +43,23 @@ class cffi_build(build): """ def finalize_options(self): - from cryptography.hazmat.bindings.openssl.binding import Binding + from cryptography.hazmat.bindings.commoncrypto.binding import ( + Binding as CommonCryptoBinding + ) + from cryptography.hazmat.bindings.openssl.binding import ( + Binding as OpenSSLBinding + ) from cryptography.hazmat.primitives import constant_time, padding self.distribution.ext_modules = [ - Binding().ffi.verifier.get_extension(), + OpenSSLBinding().ffi.verifier.get_extension(), constant_time._ffi.verifier.get_extension(), padding._ffi.verifier.get_extension() ] + if CommonCryptoBinding.is_available(): + self.distribution.ext_modules.append( + CommonCryptoBinding().ffi.verifier.get_extension() + ) build.finalize_options(self) |