aboutsummaryrefslogtreecommitdiffstats
path: root/tasks.py
diff options
context:
space:
mode:
authorAlex Stapleton <alexs@prol.etari.at>2014-03-14 20:03:12 +0000
committerAlex Stapleton <alexs@prol.etari.at>2014-03-24 09:46:47 +0000
commita39a319b096b1b2b1775ae1a91117c19422a6c81 (patch)
treeda7d4dbf73d815f835dcf38a4d62d73b742480d2 /tasks.py
parent68e77c752b94c2531f83589c1bb2060c5ed0d886 (diff)
downloadcryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.tar.gz
cryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.tar.bz2
cryptography-a39a319b096b1b2b1775ae1a91117c19422a6c81.zip
Move cryptography.vectors to cryptography_vectors
All vectors are now stored in the subpackage in the vectors/ folder. This package is automatically installed by setup.py test and will also be uploaded with a matching version number by the PyPI upload task.
Diffstat (limited to 'tasks.py')
-rw-r--r--tasks.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/tasks.py b/tasks.py
index 8e6cdab5..c124560e 100644
--- a/tasks.py
+++ b/tasks.py
@@ -84,7 +84,12 @@ def release(version):
invoke.run("git push --tags")
invoke.run("python setup.py sdist")
- invoke.run("twine upload -s dist/cryptography-{0}*".format(version))
+ invoke.run("python vectors/setup.py sdist")
+
+ invoke.run(
+ "twine upload -s dist/cryptography-{0}* "
+ "dist/cryptography_vectors-{0}*".format(version)
+ )
token = getpass.getpass("Input the Jenkins token: ")
response = requests.post(