aboutsummaryrefslogtreecommitdiffstats
path: root/tests/utils.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
commit327742c8e6271e2b6d809e891bd8e518b89994d9 (patch)
tree324a70bd84ddbc3490f20c0e3413ef1ecc6e3315 /tests/utils.py
parenteba623f88260a9a076ce3a4a71d1d61755327e05 (diff)
parentf96db83a64bb0ac40d04d27383d7c2defbcec491 (diff)
downloadcryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.gz
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.bz2
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.zip
Merge branch 'master' into setup-install-extension
Conflicts: setup.py
Diffstat (limited to 'tests/utils.py')
-rw-r--r--tests/utils.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/utils.py b/tests/utils.py
index beb2ca5d..693a0c8f 100644
--- a/tests/utils.py
+++ b/tests/utils.py
@@ -28,7 +28,9 @@ def check_backend_support(item):
supported = item.keywords.get("supported")
if supported and "backend" in item.funcargs:
if not supported.kwargs["only_if"](item.funcargs["backend"]):
- pytest.skip(supported.kwargs["skip_message"])
+ pytest.skip("{0} ({1})".format(
+ supported.kwargs["skip_message"], item.funcargs["backend"]
+ ))
elif supported:
raise ValueError("This mark is only available on methods that take a "
"backend")