aboutsummaryrefslogtreecommitdiffstats
path: root/pathod/examples/test_setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2016-02-15 14:58:49 +0100
committerMaximilian Hils <git@maximilianhils.com>2016-02-15 14:58:49 +0100
commit175ce43a30559115c08e41e5d87519e957ff96f6 (patch)
tree9231c6396d15b70601492458b33f44bfe579233b /pathod/examples/test_setup.py
parent43c3e164ecf13b2d0909f748c2c61f39e197659e (diff)
parente8598f5f7a613d7d27130de970b4c0045b3ee0d1 (diff)
downloadmitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.tar.gz
mitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.tar.bz2
mitmproxy-175ce43a30559115c08e41e5d87519e957ff96f6.zip
add pathod
Diffstat (limited to 'pathod/examples/test_setup.py')
-rw-r--r--pathod/examples/test_setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/pathod/examples/test_setup.py b/pathod/examples/test_setup.py
new file mode 100644
index 00000000..6085c98a
--- /dev/null
+++ b/pathod/examples/test_setup.py
@@ -0,0 +1,31 @@
+import requests
+from libpathod import test
+
+
+class Test:
+
+ """
+ Testing the requests module with
+ a pathod instance started for
+ each test.
+ """
+
+ def setup(self):
+ self.d = test.Daemon()
+
+ def teardown(self):
+ self.d.shutdown()
+
+ def test_simple(self):
+ # Get a URL for a pathod spec
+ url = self.d.p("200:b@100")
+ # ... and request it
+ r = requests.put(url)
+
+ # Check the returned data
+ assert r.status_code == 200
+ assert len(r.content) == 100
+
+ # Check pathod's internal log
+ log = self.d.last_log()["request"]
+ assert log["method"] == "PUT"