aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAngel Pons <th3fanbus@gmail.com>2021-04-18 13:19:51 +0000
committerNico Huber <nico.h@gmx.de>2021-04-22 11:24:29 +0000
commit02be851a63ee23fd0f9e8103504a61d26a48afc5 (patch)
treef0e5d459d80f12a8d53daf2dfe36a4507bae7612 /Makefile
parent3c97998aea8bced868fc73dfed7561fdf3382466 (diff)
downloadflashrom-02be851a63ee23fd0f9e8103504a61d26a48afc5.tar.gz
flashrom-02be851a63ee23fd0f9e8103504a61d26a48afc5.tar.bz2
flashrom-02be851a63ee23fd0f9e8103504a61d26a48afc5.zip
Revert "Makefile: Explicitly set '-std=c99'"
This reverts commit 5e5c3f15efe262ff23642dd543faf6a9dbb3bbdb. Reason for revert: Breaks building on PowerPC, NetBSD, DJGPP, and it is possible that SPARC fails to build as well. Change-Id: I57b5125207de3fd156dface67cba605da893d6aa Signed-off-by: Angel Pons <th3fanbus@gmail.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/52425 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Anastasia Klimchuk <aklm@chromium.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d496a9a3..dd19e141 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ INSTALL = install
DIFF = diff
PREFIX ?= /usr/local
MANDIR ?= $(PREFIX)/share/man
-CFLAGS ?= -std=c99 -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L -D_BSD_SOURCE -Os -Wall -Wextra -Wno-unused-parameter -Wshadow -Wmissing-prototypes -Wwrite-strings
+CFLAGS ?= -Os -Wall -Wextra -Wno-unused-parameter -Wshadow -Wmissing-prototypes -Wwrite-strings
EXPORTDIR ?= .
RANLIB ?= ranlib
PKG_CONFIG ?= pkg-config