aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNico Huber <nico.h@gmx.de>2021-06-27 13:35:21 +0200
committerNico Huber <nico.h@gmx.de>2021-07-12 11:04:11 +0000
commit9b9717b15455636dcedd561935ca82cfc7ce0b17 (patch)
treed547a11069c7b370c243ce05758d5bc98fea59cd /Makefile
parent9d6d63e9fb8bb6c0db6a64e11c2f10fb01cebd08 (diff)
downloadflashrom-9b9717b15455636dcedd561935ca82cfc7ce0b17.tar.gz
flashrom-9b9717b15455636dcedd561935ca82cfc7ce0b17.tar.bz2
flashrom-9b9717b15455636dcedd561935ca82cfc7ce0b17.zip
Makefile: Add macro to disable unsupported programmers
`mark_unsupported` disables all programmers passed as arguments and adds them to the UNSUPPORTED_FEATURES list. It's conveniently used with our dependency lists, e.g. $(call mark_unsupported,$(NEEDS_LIBUSB1) $(NEEDS_LIBFTDI)) Change-Id: I6c9b66dfa89ec3d71675576d03fcebfdea30ce7b Signed-off-by: Nico Huber <nico.h@gmx.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/55873 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e0913765..1ddc34b2 100644
--- a/Makefile
+++ b/Makefile
@@ -133,6 +133,13 @@ DEPENDS_ON_LIBFTDI := \
DEPENDS_ON_LIBJAYLINK := \
CONFIG_JLINK_SPI \
+define mark_unsupported
+$(foreach p,$1, \
+ $(if $(filter $($(p)),yes), \
+ $(eval UNSUPPORTED_FEATURES += $(p)=yes), \
+ $(eval override $(p) := no)))
+endef
+
###############################################################################
# General OS-specific settings.
# 1. Prepare for later by gathering information about host and target OS