aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e0913765..1ddc34b2 100644
--- a/Makefile
+++ b/Makefile
@@ -133,6 +133,13 @@ DEPENDS_ON_LIBFTDI := \
DEPENDS_ON_LIBJAYLINK := \
CONFIG_JLINK_SPI \
+define mark_unsupported
+$(foreach p,$1, \
+ $(if $(filter $($(p)),yes), \
+ $(eval UNSUPPORTED_FEATURES += $(p)=yes), \
+ $(eval override $(p) := no)))
+endef
+
###############################################################################
# General OS-specific settings.
# 1. Prepare for later by gathering information about host and target OS