aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.com>2022-02-19 22:31:32 +0100
committerNico Huber <nico.h@gmx.de>2022-04-13 11:15:10 +0000
commit82604bd738ce34f37a1e0c679930ae27fa10ffc0 (patch)
tree12829a6e817b4451caefae7c996ec3dab3cd4608 /meson.build
parentc4569441704da6ea7824c7cf063c1ebd2f226590 (diff)
downloadflashrom-82604bd738ce34f37a1e0c679930ae27fa10ffc0.tar.gz
flashrom-82604bd738ce34f37a1e0c679930ae27fa10ffc0.tar.bz2
flashrom-82604bd738ce34f37a1e0c679930ae27fa10ffc0.zip
hwaccess: add endianness converting deserialization functions
Add functions like `uint32_t read_le32(const void *base, size_t offset);` Read a 32 bit unsigned from a base with an offset. Having prototypes and a macro generated implementation makes it easier to read, understand and spot errors in one of them. Change-Id: Idde177acf8bc5f94cd046b6539dc31532c98e452 Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/31016 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Angel Pons <th3fanbus@gmail.com> Reviewed-by: Nico Huber <nico.h@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c84c5ded..5a6bc2ad 100644
--- a/meson.build
+++ b/meson.build
@@ -135,6 +135,8 @@ if cc.check_header('sys/utsname.h')
add_project_arguments('-DHAVE_UTSNAME=1', language : 'c')
endif
+srcs += 'platform/memaccess.c'
+
if host_machine.endian() == 'little'
srcs += 'platform/endian_little.c'
add_project_arguments('-D__FLASHROM_LITTLE_ENDIAN__=1', language : 'c')