aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUnai Martinez-Corral <38422348+umarcor@users.noreply.github.com>2022-01-11 11:03:32 +0100
committerGitHub <noreply@github.com>2022-01-11 11:03:32 +0100
commitc9b05e481423c55ffcbb856fd5296701f670808c (patch)
tree494df7a216c82222bfe3450d8aaa0bf020c9a28e
parent09a32cd13c3335e3231d6ccd32c033826c6a3798 (diff)
parent3db55b30082047a7a1b80c718bdb8d8e3fa85848 (diff)
downloadghdl-yosys-plugin-c9b05e481423c55ffcbb856fd5296701f670808c.tar.gz
ghdl-yosys-plugin-c9b05e481423c55ffcbb856fd5296701f670808c.tar.bz2
ghdl-yosys-plugin-c9b05e481423c55ffcbb856fd5296701f670808c.zip
Makefile: patches regarding DESTDIR and plugin install dir (#166)
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c2d9d25..870319d 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ LIBGHDL_LIB:=$(shell $(GHDL) --libghdl-library-path)
LIBGHDL_INC:=$(shell $(GHDL) --libghdl-include-dir)
ALL_LDFLAGS=$(LIBGHDL_LIB) -Wl,-rpath,$(dir $(LIBGHDL_LIB)) $(LDFLAGS)
+PLUGINDIR:=$(shell $(YOSYS_CONFIG) --datdir)/plugins
ALL_CFLAGS=-fPIC -DYOSYS_ENABLE_GHDL -I$(LIBGHDL_INC) $(CFLAGS)
@@ -29,8 +30,8 @@ clean: force
$(RM) -f ghdl.$(SOEXT) ghdl.o
install: ghdl.$(SOEXT)
- $(YOSYS_CONFIG) --exec mkdir -p --datdir/plugins
- $(YOSYS_CONFIG) --exec cp $< --datdir/plugins
+ $(YOSYS_CONFIG) --exec mkdir -p $(DESTDIR)$(PLUGINDIR)
+ $(YOSYS_CONFIG) --exec cp $< $(DESTDIR)$(PLUGINDIR)
-include src/ghdl.d