aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c2d9d25..870319d 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ LIBGHDL_LIB:=$(shell $(GHDL) --libghdl-library-path)
LIBGHDL_INC:=$(shell $(GHDL) --libghdl-include-dir)
ALL_LDFLAGS=$(LIBGHDL_LIB) -Wl,-rpath,$(dir $(LIBGHDL_LIB)) $(LDFLAGS)
+PLUGINDIR:=$(shell $(YOSYS_CONFIG) --datdir)/plugins
ALL_CFLAGS=-fPIC -DYOSYS_ENABLE_GHDL -I$(LIBGHDL_INC) $(CFLAGS)
@@ -29,8 +30,8 @@ clean: force
$(RM) -f ghdl.$(SOEXT) ghdl.o
install: ghdl.$(SOEXT)
- $(YOSYS_CONFIG) --exec mkdir -p --datdir/plugins
- $(YOSYS_CONFIG) --exec cp $< --datdir/plugins
+ $(YOSYS_CONFIG) --exec mkdir -p $(DESTDIR)$(PLUGINDIR)
+ $(YOSYS_CONFIG) --exec cp $< $(DESTDIR)$(PLUGINDIR)
-include src/ghdl.d