aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2017-02-02 21:37:23 +0100
committerTristan Gingold <tgingold@free.fr>2017-02-02 21:37:23 +0100
commitb93ac813080a942f799e8bbd0f1b4245d2765166 (patch)
tree101644928f2375ea03855fac42b0a0fa15cfc8c2
parent969230e344a54d91778badd80c3d4e35a70145a6 (diff)
downloadghdl-b93ac813080a942f799e8bbd0f1b4245d2765166.tar.gz
ghdl-b93ac813080a942f799e8bbd0f1b4245d2765166.tar.bz2
ghdl-b93ac813080a942f799e8bbd0f1b4245d2765166.zip
Makefile: add install.libghdlsynth
-rw-r--r--Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index ac61815cf..b2d84f53a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -300,6 +300,12 @@ libghdlsynth.a: $(GRT_ADD_OBJS) $(GRT_SRC_DEPS) version.ads force
$(RM) -f $@
ar rc $@ b~libghdlsynth.o `cat ghdlsynth.files` $(GRT_ADD_OBJS)
+install.libghdlsynth: libghdlsynth.a install.dirs
+ $(INSTALL_DATA) -p libghdlsynth.a $(DESTDIR)$(libdir)/
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/ghdlsynth.h $(DESTDIR)$(incdir)/
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/ghdlsynth_gates.h $(DESTDIR)$(incdir)/
+ $(INSTALL_DATA) -p ghdlsynth.link $(DESTDIR)$(libdir)/
+
################ ghwdump #################################################
GHWDUMP_OBJS=ghwdump.o ghwlib.o