aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2020-12-27 22:10:38 +0100
committerumarcor <unai.martinezcorral@ehu.eus>2020-12-27 23:13:21 +0100
commitbf74a0983c2d534e217e7312ab559ca8929ff8a2 (patch)
treefb630d5b83afc2f112996ebb5f1eac44de868132
parent340fc792bba2ffdb4f930bc427a39ea3a1b659b2 (diff)
downloadghdl-bf74a0983c2d534e217e7312ab559ca8929ff8a2.tar.gz
ghdl-bf74a0983c2d534e217e7312ab559ca8929ff8a2.tar.bz2
ghdl-bf74a0983c2d534e217e7312ab559ca8929ff8a2.zip
rework 'python', rename to 'pyGHDL'
* Rename 'python' to 'pyGHDL'. * Let 'thin' be 'libghdl'. * Move move 'pyutils.py' from 'python/libghdl/vhdl' to a separate package ('pyGHDL/libghdl/utils/'). * Update 'vhdl_langserver' accordingly. * Rename 'vhdl_langserver' to 'lsp'. * Move 'ghdl-ls' to 'pyGHDL/cli'.
-rwxr-xr-xpyGHDL/cli/ghdl-ls (renamed from python/ghdl-ls)2
-rw-r--r--pyGHDL/libghdl/__init__.py (renamed from python/libghdl/__init__.py)0
-rw-r--r--pyGHDL/libghdl/errorout.py (renamed from python/libghdl/thin/errorout.py)0
-rw-r--r--pyGHDL/libghdl/errorout_console.py (renamed from python/libghdl/thin/errorout_console.py)0
-rw-r--r--pyGHDL/libghdl/errorout_memory.py (renamed from python/libghdl/thin/errorout_memory.py)0
-rw-r--r--pyGHDL/libghdl/files_map.py (renamed from python/libghdl/thin/files_map.py)0
-rw-r--r--pyGHDL/libghdl/files_map_editor.py (renamed from python/libghdl/thin/files_map_editor.py)0
-rw-r--r--pyGHDL/libghdl/flags.py (renamed from python/libghdl/thin/flags.py)0
-rw-r--r--pyGHDL/libghdl/libraries.py (renamed from python/libghdl/thin/libraries.py)0
-rw-r--r--pyGHDL/libghdl/name_table.py (renamed from python/libghdl/thin/name_table.py)0
-rw-r--r--pyGHDL/libghdl/std_names.py (renamed from python/libghdl/thin/std_names.py)0
-rw-r--r--pyGHDL/libghdl/utils/__init__.py (renamed from python/libghdl/thin/vhdl/pyutils.py)12
-rw-r--r--pyGHDL/libghdl/version.py (renamed from python/libghdl/version.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/__init__.py (renamed from python/libghdl/thin/__init__.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/canon.py (renamed from python/libghdl/thin/vhdl/canon.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/elocations.py (renamed from python/libghdl/thin/vhdl/elocations.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/flists.py (renamed from python/libghdl/thin/vhdl/flists.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/formatters.py (renamed from python/libghdl/thin/vhdl/formatters.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/ieee.py (renamed from python/libghdl/thin/vhdl/ieee.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/lists.py (renamed from python/libghdl/thin/vhdl/lists.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/nodes.py (renamed from python/libghdl/thin/vhdl/nodes.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/nodes_meta.py (renamed from python/libghdl/thin/vhdl/nodes_meta.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/nodes_utils.py (renamed from python/libghdl/thin/vhdl/nodes_utils.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/parse.py (renamed from python/libghdl/thin/vhdl/parse.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/scanner.py (renamed from python/libghdl/thin/vhdl/scanner.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/sem.py (renamed from python/libghdl/thin/vhdl/sem.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/sem_lib.py (renamed from python/libghdl/thin/vhdl/sem_lib.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/std_package.py (renamed from python/libghdl/thin/vhdl/std_package.py)0
-rw-r--r--pyGHDL/libghdl/vhdl/tokens.py (renamed from python/libghdl/thin/vhdl/tokens.py)0
-rw-r--r--pyGHDL/lsp/README (renamed from python/README)0
-rw-r--r--pyGHDL/lsp/__init__.py (renamed from python/libghdl/thin/vhdl/__init__.py)0
-rw-r--r--pyGHDL/lsp/document.py (renamed from python/vhdl_langserver/document.py)18
-rw-r--r--pyGHDL/lsp/lsp.py (renamed from python/vhdl_langserver/lsp.py)0
-rw-r--r--pyGHDL/lsp/lsptools.py (renamed from python/vhdl_langserver/lsptools.py)0
-rw-r--r--pyGHDL/lsp/main.py (renamed from python/vhdl_langserver/main.py)5
-rw-r--r--pyGHDL/lsp/references.py (renamed from python/vhdl_langserver/references.py)8
-rw-r--r--pyGHDL/lsp/symbols.py (renamed from python/vhdl_langserver/symbols.py)12
-rw-r--r--pyGHDL/lsp/version.py (renamed from python/vhdl_langserver/version.py)0
-rw-r--r--pyGHDL/lsp/vhdl_ls.py (renamed from python/vhdl_langserver/vhdl_ls.py)0
-rw-r--r--pyGHDL/lsp/workspace.py (renamed from python/vhdl_langserver/workspace.py)38
-rw-r--r--pyGHDL/setup.py (renamed from python/setup.py)12
-rwxr-xr-xpyGHDL/xtools/pnodes.py (renamed from python/xtools/pnodes.py)0
-rwxr-xr-xpyGHDL/xtools/pnodespy.py (renamed from python/xtools/pnodespy.py)0
-rw-r--r--python/vhdl_langserver/__init__.py0
44 files changed, 52 insertions, 55 deletions
diff --git a/python/ghdl-ls b/pyGHDL/cli/ghdl-ls
index 2fa44dcaa..9ca41f5ca 100755
--- a/python/ghdl-ls
+++ b/pyGHDL/cli/ghdl-ls
@@ -1,4 +1,4 @@
#! /usr/bin/env python3
-import vhdl_langserver.main as main
+import pyGHDL.lsp.main as main
main.main()
diff --git a/python/libghdl/__init__.py b/pyGHDL/libghdl/__init__.py
index 4ba7b6b26..4ba7b6b26 100644
--- a/python/libghdl/__init__.py
+++ b/pyGHDL/libghdl/__init__.py
diff --git a/python/libghdl/thin/errorout.py b/pyGHDL/libghdl/errorout.py
index af0da5fc6..af0da5fc6 100644
--- a/python/libghdl/thin/errorout.py
+++ b/pyGHDL/libghdl/errorout.py
diff --git a/python/libghdl/thin/errorout_console.py b/pyGHDL/libghdl/errorout_console.py
index 877165b70..877165b70 100644
--- a/python/libghdl/thin/errorout_console.py
+++ b/pyGHDL/libghdl/errorout_console.py
diff --git a/python/libghdl/thin/errorout_memory.py b/pyGHDL/libghdl/errorout_memory.py
index f236f1075..f236f1075 100644
--- a/python/libghdl/thin/errorout_memory.py
+++ b/pyGHDL/libghdl/errorout_memory.py
diff --git a/python/libghdl/thin/files_map.py b/pyGHDL/libghdl/files_map.py
index d27209e7a..d27209e7a 100644
--- a/python/libghdl/thin/files_map.py
+++ b/pyGHDL/libghdl/files_map.py
diff --git a/python/libghdl/thin/files_map_editor.py b/pyGHDL/libghdl/files_map_editor.py
index bf9492786..bf9492786 100644
--- a/python/libghdl/thin/files_map_editor.py
+++ b/pyGHDL/libghdl/files_map_editor.py
diff --git a/python/libghdl/thin/flags.py b/pyGHDL/libghdl/flags.py
index 3a82950a0..3a82950a0 100644
--- a/python/libghdl/thin/flags.py
+++ b/pyGHDL/libghdl/flags.py
diff --git a/python/libghdl/thin/libraries.py b/pyGHDL/libghdl/libraries.py
index 625f7fdd1..625f7fdd1 100644
--- a/python/libghdl/thin/libraries.py
+++ b/pyGHDL/libghdl/libraries.py
diff --git a/python/libghdl/thin/name_table.py b/pyGHDL/libghdl/name_table.py
index c41973ec1..c41973ec1 100644
--- a/python/libghdl/thin/name_table.py
+++ b/pyGHDL/libghdl/name_table.py
diff --git a/python/libghdl/thin/std_names.py b/pyGHDL/libghdl/std_names.py
index 540d37c33..540d37c33 100644
--- a/python/libghdl/thin/std_names.py
+++ b/pyGHDL/libghdl/std_names.py
diff --git a/python/libghdl/thin/vhdl/pyutils.py b/pyGHDL/libghdl/utils/__init__.py
index ba041d323..a8e0d4f3f 100644
--- a/python/libghdl/thin/vhdl/pyutils.py
+++ b/pyGHDL/libghdl/utils/__init__.py
@@ -1,10 +1,10 @@
from ctypes import c_char_p, c_int32, c_int, c_bool, sizeof, c_void_p, byref
-import libghdl.thin.name_table as name_table
-import libghdl.thin.vhdl.nodes as nodes
-import libghdl.thin.vhdl.nodes_meta as nodes_meta
-import libghdl.thin.vhdl.lists as lists
-import libghdl.thin.vhdl.flists as flists
-from libghdl.thin.vhdl.nodes_meta import Attr, types
+import pyGHDL.libghdl.name_table as name_table
+import pyGHDL.libghdl.vhdl.nodes as nodes
+import pyGHDL.libghdl.vhdl.nodes_meta as nodes_meta
+import pyGHDL.libghdl.vhdl.lists as lists
+import pyGHDL.libghdl.vhdl.flists as flists
+from pyGHDL.libghdl.vhdl.nodes_meta import Attr, types
def name_image(nameid):
diff --git a/python/libghdl/version.py b/pyGHDL/libghdl/version.py
index fcc6d13d8..fcc6d13d8 100644
--- a/python/libghdl/version.py
+++ b/pyGHDL/libghdl/version.py
diff --git a/python/libghdl/thin/__init__.py b/pyGHDL/libghdl/vhdl/__init__.py
index e69de29bb..e69de29bb 100644
--- a/python/libghdl/thin/__init__.py
+++ b/pyGHDL/libghdl/vhdl/__init__.py
diff --git a/python/libghdl/thin/vhdl/canon.py b/pyGHDL/libghdl/vhdl/canon.py
index 7893cf3ff..7893cf3ff 100644
--- a/python/libghdl/thin/vhdl/canon.py
+++ b/pyGHDL/libghdl/vhdl/canon.py
diff --git a/python/libghdl/thin/vhdl/elocations.py b/pyGHDL/libghdl/vhdl/elocations.py
index 87d87b731..87d87b731 100644
--- a/python/libghdl/thin/vhdl/elocations.py
+++ b/pyGHDL/libghdl/vhdl/elocations.py
diff --git a/python/libghdl/thin/vhdl/flists.py b/pyGHDL/libghdl/vhdl/flists.py
index 6cdd39ff3..6cdd39ff3 100644
--- a/python/libghdl/thin/vhdl/flists.py
+++ b/pyGHDL/libghdl/vhdl/flists.py
diff --git a/python/libghdl/thin/vhdl/formatters.py b/pyGHDL/libghdl/vhdl/formatters.py
index 9c8bf9afb..9c8bf9afb 100644
--- a/python/libghdl/thin/vhdl/formatters.py
+++ b/pyGHDL/libghdl/vhdl/formatters.py
diff --git a/python/libghdl/thin/vhdl/ieee.py b/pyGHDL/libghdl/vhdl/ieee.py
index 35db1a631..35db1a631 100644
--- a/python/libghdl/thin/vhdl/ieee.py
+++ b/pyGHDL/libghdl/vhdl/ieee.py
diff --git a/python/libghdl/thin/vhdl/lists.py b/pyGHDL/libghdl/vhdl/lists.py
index bcaecb89b..bcaecb89b 100644
--- a/python/libghdl/thin/vhdl/lists.py
+++ b/pyGHDL/libghdl/vhdl/lists.py
diff --git a/python/libghdl/thin/vhdl/nodes.py b/pyGHDL/libghdl/vhdl/nodes.py
index e7f47b16f..e7f47b16f 100644
--- a/python/libghdl/thin/vhdl/nodes.py
+++ b/pyGHDL/libghdl/vhdl/nodes.py
diff --git a/python/libghdl/thin/vhdl/nodes_meta.py b/pyGHDL/libghdl/vhdl/nodes_meta.py
index 245a847cf..245a847cf 100644
--- a/python/libghdl/thin/vhdl/nodes_meta.py
+++ b/pyGHDL/libghdl/vhdl/nodes_meta.py
diff --git a/python/libghdl/thin/vhdl/nodes_utils.py b/pyGHDL/libghdl/vhdl/nodes_utils.py
index caee7ac4a..caee7ac4a 100644
--- a/python/libghdl/thin/vhdl/nodes_utils.py
+++ b/pyGHDL/libghdl/vhdl/nodes_utils.py
diff --git a/python/libghdl/thin/vhdl/parse.py b/pyGHDL/libghdl/vhdl/parse.py
index 4fff64b84..4fff64b84 100644
--- a/python/libghdl/thin/vhdl/parse.py
+++ b/pyGHDL/libghdl/vhdl/parse.py
diff --git a/python/libghdl/thin/vhdl/scanner.py b/pyGHDL/libghdl/vhdl/scanner.py
index 8cea66ba3..8cea66ba3 100644
--- a/python/libghdl/thin/vhdl/scanner.py
+++ b/pyGHDL/libghdl/vhdl/scanner.py
diff --git a/python/libghdl/thin/vhdl/sem.py b/pyGHDL/libghdl/vhdl/sem.py
index df82435da..df82435da 100644
--- a/python/libghdl/thin/vhdl/sem.py
+++ b/pyGHDL/libghdl/vhdl/sem.py
diff --git a/python/libghdl/thin/vhdl/sem_lib.py b/pyGHDL/libghdl/vhdl/sem_lib.py
index 36559ec5e..36559ec5e 100644
--- a/python/libghdl/thin/vhdl/sem_lib.py
+++ b/pyGHDL/libghdl/vhdl/sem_lib.py
diff --git a/python/libghdl/thin/vhdl/std_package.py b/pyGHDL/libghdl/vhdl/std_package.py
index d999ae8b9..d999ae8b9 100644
--- a/python/libghdl/thin/vhdl/std_package.py
+++ b/pyGHDL/libghdl/vhdl/std_package.py
diff --git a/python/libghdl/thin/vhdl/tokens.py b/pyGHDL/libghdl/vhdl/tokens.py
index 002e7ca82..002e7ca82 100644
--- a/python/libghdl/thin/vhdl/tokens.py
+++ b/pyGHDL/libghdl/vhdl/tokens.py
diff --git a/python/README b/pyGHDL/lsp/README
index c82ccc4d4..c82ccc4d4 100644
--- a/python/README
+++ b/pyGHDL/lsp/README
diff --git a/python/libghdl/thin/vhdl/__init__.py b/pyGHDL/lsp/__init__.py
index e69de29bb..e69de29bb 100644
--- a/python/libghdl/thin/vhdl/__init__.py
+++ b/pyGHDL/lsp/__init__.py
diff --git a/python/vhdl_langserver/document.py b/pyGHDL/lsp/document.py
index 82d11fe56..1b988220c 100644
--- a/python/vhdl_langserver/document.py
+++ b/pyGHDL/lsp/document.py
@@ -1,14 +1,14 @@
import ctypes
import logging
import os
-import libghdl.thin.name_table as name_table
-import libghdl.thin.files_map as files_map
-import libghdl.thin.files_map_editor as files_map_editor
-import libghdl.thin.libraries as libraries
-import libghdl.thin.vhdl.nodes as nodes
-import libghdl.thin.vhdl.sem_lib as sem_lib
-import libghdl.thin.vhdl.sem as sem
-import libghdl.thin.vhdl.formatters as formatters
+import pyGHDL.libghdl.name_table as name_table
+import pyGHDL.libghdl.files_map as files_map
+import pyGHDL.libghdl.files_map_editor as files_map_editor
+import pyGHDL.libghdl.libraries as libraries
+import pyGHDL.libghdl.vhdl.nodes as nodes
+import pyGHDL.libghdl.vhdl.sem_lib as sem_lib
+import pyGHDL.libghdl.vhdl.sem as sem
+import pyGHDL.libghdl.vhdl.formatters as formatters
from . import symbols, references
@@ -67,7 +67,7 @@ class Document(object):
if not change_range:
# The whole file has changed
raise AssertionError
- # if len(text_bytes) < thin.Files_Map.Get_Buffer_Length(self._fe):
+ # if len(text_bytes) < libghdl.Files_Map.Get_Buffer_Length(self._fe):
# xxxx_replace
# else:
# xxxx_free
diff --git a/python/vhdl_langserver/lsp.py b/pyGHDL/lsp/lsp.py
index 60f32be76..60f32be76 100644
--- a/python/vhdl_langserver/lsp.py
+++ b/pyGHDL/lsp/lsp.py
diff --git a/python/vhdl_langserver/lsptools.py b/pyGHDL/lsp/lsptools.py
index 648f0a8c0..648f0a8c0 100644
--- a/python/vhdl_langserver/lsptools.py
+++ b/pyGHDL/lsp/lsptools.py
diff --git a/python/vhdl_langserver/main.py b/pyGHDL/lsp/main.py
index 5fe0e0549..7cfe06683 100644
--- a/python/vhdl_langserver/main.py
+++ b/pyGHDL/lsp/main.py
@@ -6,8 +6,7 @@ import logging
import sys
import os
-import libghdl
-import libghdl.thin.errorout_console
+import pyGHDL.libghdl as libghdl
from . import version
from . import lsp
@@ -72,7 +71,7 @@ def main():
args = parser.parse_args()
if args.disp_config:
- libghdl.thin.errorout_console.Install_Handler()
+ libghdl.errorout_console.Install_Handler()
libghdl.disp_config()
return
diff --git a/python/vhdl_langserver/references.py b/pyGHDL/lsp/references.py
index f716548eb..65bbeead4 100644
--- a/python/vhdl_langserver/references.py
+++ b/pyGHDL/lsp/references.py
@@ -1,8 +1,8 @@
import logging
-import libghdl.thin.vhdl.nodes as nodes
-import libghdl.thin.vhdl.nodes_meta as nodes_meta
-import libghdl.thin.vhdl.pyutils as pyutils
-import libghdl.thin.name_table as name_table
+import pyGHDL.libghdl.vhdl.nodes as nodes
+import pyGHDL.libghdl.vhdl.nodes_meta as nodes_meta
+import pyGHDL.libghdl.name_table as name_table
+import pyGHDL.libghdl.utils as pyutils
log = logging.getLogger(__name__)
diff --git a/python/vhdl_langserver/symbols.py b/pyGHDL/lsp/symbols.py
index d0bd269de..3a0f1da30 100644
--- a/python/vhdl_langserver/symbols.py
+++ b/pyGHDL/lsp/symbols.py
@@ -1,9 +1,9 @@
-import libghdl.thin.name_table as name_table
-import libghdl.thin.files_map as files_map
-import libghdl.thin.vhdl.pyutils as pyutils
-import libghdl.thin.vhdl.nodes as nodes
-import libghdl.thin.vhdl.nodes_meta as nodes_meta
-import libghdl.thin.vhdl.elocations as elocations
+import pyGHDL.libghdl.name_table as name_table
+import pyGHDL.libghdl.files_map as files_map
+import pyGHDL.libghdl.vhdl.nodes as nodes
+import pyGHDL.libghdl.vhdl.nodes_meta as nodes_meta
+import pyGHDL.libghdl.vhdl.elocations as elocations
+import pyGHDL.libghdl.utils as pyutils
from . import lsp
diff --git a/python/vhdl_langserver/version.py b/pyGHDL/lsp/version.py
index 4b0d124d5..4b0d124d5 100644
--- a/python/vhdl_langserver/version.py
+++ b/pyGHDL/lsp/version.py
diff --git a/python/vhdl_langserver/vhdl_ls.py b/pyGHDL/lsp/vhdl_ls.py
index 61c4aed23..61c4aed23 100644
--- a/python/vhdl_langserver/vhdl_ls.py
+++ b/pyGHDL/lsp/vhdl_ls.py
diff --git a/python/vhdl_langserver/workspace.py b/pyGHDL/lsp/workspace.py
index 9d61225ee..19cdc5309 100644
--- a/python/vhdl_langserver/workspace.py
+++ b/pyGHDL/lsp/workspace.py
@@ -2,19 +2,19 @@ import logging
import os
import json
from ctypes import byref
-import libghdl
-import libghdl.thin.errorout_memory as errorout_memory
-import libghdl.thin.flags
-import libghdl.thin.errorout as errorout
-import libghdl.thin.files_map as files_map
-import libghdl.thin.libraries as libraries
-import libghdl.thin.name_table as name_table
-import libghdl.thin.vhdl.nodes as nodes
-import libghdl.thin.vhdl.lists as lists
-import libghdl.thin.vhdl.std_package as std_package
-import libghdl.thin.vhdl.parse
-import libghdl.thin.vhdl.pyutils as pyutils
-import libghdl.thin.vhdl.sem_lib as sem_lib
+import pyGHDL.libghdl as libghdl
+import pyGHDL.libghdl.errorout_memory as errorout_memory
+import pyGHDL.libghdl.flags
+import pyGHDL.libghdl.errorout as errorout
+import pyGHDL.libghdl.files_map as files_map
+import pyGHDL.libghdl.libraries as libraries
+import pyGHDL.libghdl.name_table as name_table
+import pyGHDL.libghdl.vhdl.nodes as nodes
+import pyGHDL.libghdl.vhdl.lists as lists
+import pyGHDL.libghdl.vhdl.std_package as std_package
+import pyGHDL.libghdl.vhdl.parse
+import pyGHDL.libghdl.vhdl.sem_lib as sem_lib
+import pyGHDL.libghdl.utils as pyutils
from . import lsp
from . import document, symbols
@@ -40,16 +40,16 @@ class Workspace(object):
self._prj = {}
self._last_linted_doc = None
errorout_memory.Install_Handler()
- libghdl.thin.flags.Flag_Elocations.value = True
- # thin.Flags.Verbose.value = True
+ libghdl.flags.Flag_Elocations.value = True
+ # libghdl.Flags.Verbose.value = True
# We do analysis even in case of errors.
- libghdl.thin.vhdl.parse.Flag_Parse_Parenthesis.value = True
+ libghdl.vhdl.parse.Flag_Parse_Parenthesis.value = True
# Force analysis to get more feedback + navigation even in case
# of errors.
- libghdl.thin.flags.Flag_Force_Analysis.value = True
+ libghdl.flags.Flag_Force_Analysis.value = True
# Do not consider analysis order issues.
- libghdl.thin.flags.Flag_Elaborate_With_Outdated.value = True
- libghdl.thin.errorout.Enable_Warning(errorout.Msgid.Warnid_Unused, True)
+ libghdl.flags.Flag_Elaborate_With_Outdated.value = True
+ libghdl.errorout.Enable_Warning(errorout.Msgid.Warnid_Unused, True)
self.read_project()
self.set_options_from_project()
libghdl.analyze_init()
diff --git a/python/setup.py b/pyGHDL/setup.py
index 1eec3bcf5..b76d8cd29 100644
--- a/python/setup.py
+++ b/pyGHDL/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
-from setuptools import setup
+from setuptools import setup, find_packages
import re
@@ -21,16 +21,14 @@ def get_version():
version = get_version()
setup(
- name="pyghdl",
+ name="pyGHDL",
version=version,
- description="VHDL Language Server and interface to ghdl, a VHDL analyzer",
- long_description=open("README").read(),
+ description="Python bindings for GHDL and high-level APIs (incl. LSP)",
author="Tristan Gingold",
author_email="tgingold@free.fr",
url="http://github.com/ghdl/ghdl",
license="GPL-2.0-or-later",
- package_dir={"libghdl": "libghdl", "vhdl_langserver": "vhdl_langserver"},
- packages=["libghdl", "libghdl.thin", "libghdl.thin.vhdl", "vhdl_langserver"],
+ packages=find_packages(),
# List run-time dependencies here. For an analysis of "install_requires"
# vs pip's requirements files see:
# https://packaging.python.org/en/latest/requirements.html
@@ -43,4 +41,4 @@ setup(
"ghdl-ls = vhdl_langserver.main:main",
]
},
-)
+) \ No newline at end of file
diff --git a/python/xtools/pnodes.py b/pyGHDL/xtools/pnodes.py
index 793c1c712..793c1c712 100755
--- a/python/xtools/pnodes.py
+++ b/pyGHDL/xtools/pnodes.py
diff --git a/python/xtools/pnodespy.py b/pyGHDL/xtools/pnodespy.py
index 0e0f5ba9e..0e0f5ba9e 100755
--- a/python/xtools/pnodespy.py
+++ b/pyGHDL/xtools/pnodespy.py
diff --git a/python/vhdl_langserver/__init__.py b/python/vhdl_langserver/__init__.py
deleted file mode 100644
index e69de29bb..000000000
--- a/python/vhdl_langserver/__init__.py
+++ /dev/null