aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorXiretza <xiretza@xiretza.xyz>2022-03-17 10:14:52 +0100
committerXiretza <xiretza@xiretza.xyz>2022-03-17 10:14:52 +0100
commit8fe837a38b18a98aa7abd36386844b9729e22427 (patch)
treebfc1b34f9e9406d90b22417dd9e3fecb6fe7b10e /Makefile.in
parente7d08f71485eeeb4d0f2fcf86a4f6f78a995498d (diff)
downloadghdl-8fe837a38b18a98aa7abd36386844b9729e22427.tar.gz
ghdl-8fe837a38b18a98aa7abd36386844b9729e22427.tar.bz2
ghdl-8fe837a38b18a98aa7abd36386844b9729e22427.zip
Makefile: install.local: create required directories
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 1342b02a0..9f40d1482 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -472,6 +472,7 @@ install.libghdl.include: install.dirs $(srcdir)/src/synth/include/synth_gates.h
test: install.libghdl.local
install.libghdl.local: all.libghdl
+ $(MKDIR) -p $(incdirsuffix)/ghdl/
$(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth.h $(incdirsuffix)/ghdl/
$(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth_gates.h $(incdirsuffix)/ghdl/
@@ -571,7 +572,7 @@ uninstall.vpi:
test: install.vpi.local
install.vpi.local: all.vpi
- $(MKDIR) -p $(incdirsuffix) lib
+ $(MKDIR) -p $(incdirsuffix)/ghdl/
$(INSTALL_DATA) -p $(GRTSRCDIR)/vpi_user.h $(incdirsuffix)/ghdl/
$(INSTALL_DATA) -p $(GRTSRCDIR)/vhpi_user.h $(incdirsuffix)/ghdl/