aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2020-12-29 01:38:54 +0100
committerPatrick Lehmann <Patrick.Lehmann@plc2.de>2020-12-29 01:38:54 +0100
commit3427a61b81b542bb683e8f1e5dd376aaa184e575 (patch)
tree034e0c7d9d29282537ced35b47bc4b96bcce9e8f /setup.py
parentf170010041fd95d1705d5f73b823b25b6963b850 (diff)
downloadghdl-3427a61b81b542bb683e8f1e5dd376aaa184e575.tar.gz
ghdl-3427a61b81b542bb683e8f1e5dd376aaa184e575.tar.bz2
ghdl-3427a61b81b542bb683e8f1e5dd376aaa184e575.zip
Lowering required Python version to 3.7.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7cbb0009e..47f41fbc6 100644
--- a/setup.py
+++ b/setup.py
@@ -91,7 +91,7 @@ setuptools_setup(
'Issue Tracker': sourceCodeURL + "/issues"
},
- python_requires='>=3.8',
+ python_requires='>=3.7',
install_requires=requirements,
packages=setuptools_find_packages(exclude=("tests",)),
entry_points={
@@ -107,6 +107,7 @@ setuptools_setup(
"Operating System :: Microsoft :: Windows :: Windows 10",
"Operating System :: POSIX :: Linux",
"Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Development Status :: 4 - Beta",