aboutsummaryrefslogtreecommitdiffstats
path: root/testsuite/synth/issue1675/testsuite.sh
diff options
context:
space:
mode:
authorUnai Martinez-Corral <38422348+umarcor@users.noreply.github.com>2021-06-26 19:40:25 +0100
committerGitHub <noreply@github.com>2021-06-26 20:40:25 +0200
commitb4d4d9abb322ed0807d2ba0888e73820499aa338 (patch)
treeb980d379e95034ee72aac29955833e1ef0dfd912 /testsuite/synth/issue1675/testsuite.sh
parent111fe055b2f0f3a0225d2553cf739572d691a14d (diff)
downloadghdl-b4d4d9abb322ed0807d2ba0888e73820499aa338.tar.gz
ghdl-b4d4d9abb322ed0807d2ba0888e73820499aa338.tar.bz2
ghdl-b4d4d9abb322ed0807d2ba0888e73820499aa338.zip
Codacy issues, Travis cleanup and update ghdl.texi (#1807)
* ghw: fix memleaks reported by codacy * ghw: printf issues and style (GNU indent) * testsuite/gna: minor printf issues * testsuite: fix issues reported by codacy * scripts/ci-run: clean travis stuff (deprecated) * scripts: fix issues reported by codacy * doc/Makefile: add .PHONY * doc: update ghdl.texi * testsuite/synth: use synth_tb
Diffstat (limited to 'testsuite/synth/issue1675/testsuite.sh')
-rwxr-xr-xtestsuite/synth/issue1675/testsuite.sh36
1 files changed, 4 insertions, 32 deletions
diff --git a/testsuite/synth/issue1675/testsuite.sh b/testsuite/synth/issue1675/testsuite.sh
index 23b988cc0..833a1182f 100755
--- a/testsuite/synth/issue1675/testsuite.sh
+++ b/testsuite/synth/issue1675/testsuite.sh
@@ -3,43 +3,15 @@
. ../../testenv.sh
# accum
-analyze pkg.vhdl accum.vhdl tb_accum.vhdl
-elab_simulate tb_accum
-clean
-
-synth pkg.vhdl accum.vhdl -e > syn_accum.vhdl
-analyze pkg.vhdl syn_accum.vhdl tb_accum.vhdl
-elab_simulate tb_accum --ieee-asserts=disable-at-0 --assert-level=error
-clean
+synth_tb accum pkg.vhdl
# accumwr
-analyze pkg.vhdl accum.vhdl accumwr.vhdl tb_accumwr.vhdl
-elab_simulate tb_accumwr
-clean
-
-synth pkg.vhdl accum.vhdl accumwr.vhdl -e > syn_accumwr.vhdl
-analyze pkg.vhdl syn_accumwr.vhdl tb_accumwr.vhdl
-elab_simulate tb_accumwr --ieee-asserts=disable-at-0 --assert-level=error
-clean
+synth_tb accumwr pkg.vhdl accum.vhdl
# patgen
-analyze pkg.vhdl patgen.vhdl tb_patgen.vhdl
-elab_simulate tb_patgen
-clean
-
-synth pkg.vhdl patgen.vhdl -e > syn_patgen.vhdl
-analyze pkg.vhdl syn_patgen.vhdl tb_patgen.vhdl
-elab_simulate tb_patgen --ieee-asserts=disable-at-0 --assert-level=error
-clean
+synth_tb patgen pkg.vhdl
# patacc
-analyze pkg.vhdl patgen.vhdl patacc.vhdl tb_patacc.vhdl
-elab_simulate tb_patacc
-clean
-
-synth pkg.vhdl patgen.vhdl patacc.vhdl -e > syn_patacc.vhdl
-analyze pkg.vhdl syn_patacc.vhdl tb_patacc.vhdl
-elab_simulate tb_patacc --ieee-asserts=disable-at-0 --assert-level=error
-clean
+synth_tb patacc pkg.vhdl patgen.vhdl
echo "Test successful"