aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/libghdl/thin/vhdl/pyutils.py4
-rw-r--r--python/setup.py6
2 files changed, 7 insertions, 3 deletions
diff --git a/python/libghdl/thin/vhdl/pyutils.py b/python/libghdl/thin/vhdl/pyutils.py
index d98ae3ca4..ba041d323 100644
--- a/python/libghdl/thin/vhdl/pyutils.py
+++ b/python/libghdl/thin/vhdl/pyutils.py
@@ -298,7 +298,7 @@ def concurrent_stmts_iter(n):
def constructs_iter(n):
"""Iterator on library unit, concurrent statements and declarations
- that appear directly within a declarative part."""
+ that appear directly within a declarative part."""
if n == thin.Null_Iir:
return
k = nodes.Get_Kind(n)
@@ -365,7 +365,7 @@ def constructs_iter(n):
def sequential_iter(n):
"""Iterator on sequential statements. The first node must be either
- a process or a subprogram body."""
+ a process or a subprogram body."""
if n == thin.Null_Iir:
return
k = nodes.Get_Kind(n)
diff --git a/python/setup.py b/python/setup.py
index 1c4324bde..1eec3bcf5 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -38,5 +38,9 @@ setup(
# To provide executable scripts, use entry points in preference to the
# "scripts" keyword. Entry points provide cross-platform support and allow
# pip to create the appropriate form of executable for the target platform.
- entry_points={"console_scripts": ["ghdl-ls = vhdl_langserver.main:main",]},
+ entry_points={
+ "console_scripts": [
+ "ghdl-ls = vhdl_langserver.main:main",
+ ]
+ },
)