aboutsummaryrefslogtreecommitdiffstats
path: root/testsuite/gna/issue450/cocotb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/gna/issue450/cocotb/Makefile')
-rw-r--r--testsuite/gna/issue450/cocotb/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/testsuite/gna/issue450/cocotb/Makefile b/testsuite/gna/issue450/cocotb/Makefile
new file mode 100644
index 000000000..e740fd2a2
--- /dev/null
+++ b/testsuite/gna/issue450/cocotb/Makefile
@@ -0,0 +1,17 @@
+CWD = $(shell pwd)
+COCOTB = $(CWD)/../../..
+
+TOPLEVEL_LANG = vhdl
+
+VHDL_SOURCES = $(CWD)/../hdl/top.vhd
+
+SIM = ghdl
+CMD_BIN = ghdl
+
+TOPLEVEL=top
+MODULE=$(TOPLEVEL)_cocotb
+
+include $(COCOTB)/makefiles/Makefile.inc
+include $(COCOTB)/makefiles/Makefile.sim
+
+sim: $(MODULE).py