aboutsummaryrefslogtreecommitdiffstats
path: root/examples/icezum/Makefile
diff options
context:
space:
mode:
authorAki Van Ness <aki@lethalbit.net>2022-09-15 06:32:45 -0400
committerAki Van Ness <aki@lethalbit.net>2022-09-15 06:32:45 -0400
commitca43729f124466b816f922842353feeb3f6f8e84 (patch)
treedcb5191f0f33237ae561bfad064bd20fc397e728 /examples/icezum/Makefile
parent2bc541743ada3542c6da36a50e66303b9cbd2059 (diff)
downloadicestorm-ca43729f124466b816f922842353feeb3f6f8e84.tar.gz
icestorm-ca43729f124466b816f922842353feeb3f6f8e84.tar.bz2
icestorm-ca43729f124466b816f922842353feeb3f6f8e84.zip
Replaced instances of `arachne-pnr` with the `nextpnr-ice40` equivalent
Diffstat (limited to 'examples/icezum/Makefile')
-rw-r--r--examples/icezum/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/examples/icezum/Makefile b/examples/icezum/Makefile
index cad44d2..9944b95 100644
--- a/examples/icezum/Makefile
+++ b/examples/icezum/Makefile
@@ -1,14 +1,15 @@
PROJ = example
PIN_DEF = icezum.pcf
DEVICE = hx1k
+PACKAGE = tq144
all: $(PROJ).rpt $(PROJ).bin
-%.blif: %.v
- yosys -p 'synth_ice40 -top top -blif $@' $<
+%.json: %.v
+ yosys -p 'synth_ice40 -top top -json $@' $<
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
+%.asc: $(PIN_DEF) %.json
+ nextpnr-ice40 --$(DEVICE) --package $(PACKAGE) --asc $@ --pcf $< --json $*.json
%.bin: %.asc
icepack $< $@
@@ -24,7 +25,7 @@ sudo-prog: $(PROJ).bin
sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+ rm -f $(PROJ).json $(PROJ).asc $(PROJ).rpt $(PROJ).bin
.SECONDARY:
.PHONY: all prog clean