aboutsummaryrefslogtreecommitdiffstats
path: root/examples
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2016-02-01 23:32:03 +0100
committerClifford Wolf <clifford@clifford.at>2016-02-01 23:32:03 +0100
commit81c33a343ffce5eab897d0a5a7d228bfcb08aaf4 (patch)
treef1a95089b3c441b3895fc55612b5efc730b087bd /examples
parent8b6116523bdd12b9376b4ed023fee6c62bb7a714 (diff)
downloadicestorm-81c33a343ffce5eab897d0a5a7d228bfcb08aaf4.tar.gz
icestorm-81c33a343ffce5eab897d0a5a7d228bfcb08aaf4.tar.bz2
icestorm-81c33a343ffce5eab897d0a5a7d228bfcb08aaf4.zip
Timing models for LP and HX devices
Diffstat (limited to 'examples')
-rw-r--r--examples/hx8kboard/Makefile6
-rw-r--r--examples/iceblink/.gitignore4
-rw-r--r--examples/iceblink/Makefile9
-rw-r--r--examples/icestick/Makefile6
4 files changed, 16 insertions, 9 deletions
diff --git a/examples/hx8kboard/Makefile b/examples/hx8kboard/Makefile
index 0241807..bcecdf2 100644
--- a/examples/hx8kboard/Makefile
+++ b/examples/hx8kboard/Makefile
@@ -1,6 +1,6 @@
PROJ = example
PIN_DEF = hx8kboard.pcf
-DEVICE = 8k
+DEVICE = hx8k
all: $(PROJ).rpt $(PROJ).bin
@@ -8,13 +8,13 @@ all: $(PROJ).rpt $(PROJ).bin
yosys -p 'synth_ice40 -top top -blif $@' $<
%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(DEVICE) -o $@ -p $^
+ arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
%.bin: %.asc
icepack $< $@
%.rpt: %.asc
- icetime -mtr $@ $<
+ icetime -d $(DEVICE) -mtr $@ $<
prog: $(PROJ).bin
iceprog $<
diff --git a/examples/iceblink/.gitignore b/examples/iceblink/.gitignore
new file mode 100644
index 0000000..c1fa30b
--- /dev/null
+++ b/examples/iceblink/.gitignore
@@ -0,0 +1,4 @@
+example.bin
+example.blif
+example.asc
+example.rpt
diff --git a/examples/iceblink/Makefile b/examples/iceblink/Makefile
index 8f908a8..25ffe3c 100644
--- a/examples/iceblink/Makefile
+++ b/examples/iceblink/Makefile
@@ -1,18 +1,21 @@
PROJ = example
PIN_DEF = iceblink.pcf
-DEVICE = 1k
+DEVICE = hx1k
-all: $(PROJ).bin
+all: $(PROJ).rpt $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(DEVICE) -o $@ -p $^ -P vq100
+ arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^ -P vq100
%.bin: %.asc
icepack $< $@
+%.rpt: %.asc
+ icetime -d $(DEVICE) -mtr $@ $<
+
prog: $(PROJ).bin
iCEburn.py -e -v -w $<
diff --git a/examples/icestick/Makefile b/examples/icestick/Makefile
index a2ecbc6..f40c8a3 100644
--- a/examples/icestick/Makefile
+++ b/examples/icestick/Makefile
@@ -1,6 +1,6 @@
PROJ = example
PIN_DEF = icestick.pcf
-DEVICE = 1k
+DEVICE = hx1k
all: $(PROJ).rpt $(PROJ).bin
@@ -8,13 +8,13 @@ all: $(PROJ).rpt $(PROJ).bin
yosys -p 'synth_ice40 -top top -blif $@' $<
%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(DEVICE) -o $@ -p $^
+ arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
%.bin: %.asc
icepack $< $@
%.rpt: %.asc
- icetime -mtr $@ $<
+ icetime -d $(DEVICE) -mtr $@ $<
prog: $(PROJ).bin
iceprog $<