aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz
diff options
context:
space:
mode:
authorAaron Bieber <aaron@bolddaemon.com>2015-08-18 15:56:16 -0600
committerAaron Bieber <aaron@bolddaemon.com>2015-08-18 15:56:16 -0600
commit4b4511dfe90e398afa9f0501084cb1373ca967cc (patch)
tree714b67e595590135723060cb14fa6051994714b2 /icefuzz
parent235ff955e3f857a8b4353a64d5b18dd3da91f1f5 (diff)
downloadicestorm-4b4511dfe90e398afa9f0501084cb1373ca967cc.tar.gz
icestorm-4b4511dfe90e398afa9f0501084cb1373ca967cc.tar.bz2
icestorm-4b4511dfe90e398afa9f0501084cb1373ca967cc.zip
variablize CXX and PYTHON and add -L and -I
Diffstat (limited to 'icefuzz')
-rw-r--r--icefuzz/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/icefuzz/Makefile b/icefuzz/Makefile
index 8c93413..59fb433 100644
--- a/icefuzz/Makefile
+++ b/icefuzz/Makefile
@@ -27,8 +27,8 @@ else
cp cached_ramb_8k.txt bitdata_ramb_8k.txt
cp cached_ramt_8k.txt bitdata_ramt_8k.txt
endif
- python2 database.py
- python2 export.py
+ $(PYTHON) database.py
+ $(PYTHON) export.py
diff -U0 cached_io.txt bitdata_io.txt || cp -v bitdata_io.txt cached_io.txt
diff -U0 cached_logic.txt bitdata_logic.txt || cp -v bitdata_logic.txt cached_logic.txt
diff -U0 cached_ramb.txt bitdata_ramb.txt || cp -v bitdata_ramb.txt cached_ramb.txt
@@ -63,13 +63,13 @@ datafiles: $(addprefix data_,$(addsuffix .txt,$(TESTS)))
define data_template
data_$(1).txt: make_$(1).py ../icepack/icepack
ifeq ($(EIGTHK),_8k)
- ICE8KPINS=1 python2 make_$(1).py
+ ICE8KPINS=1 $(PYTHON) make_$(1).py
ICEDEV=hx8k-ct256 $$(MAKE) -C work_$(1)
- python2 extract.py -8 work_$(1)/*.glb > $$@
+ $$(PYTHON) extract.py -8 work_$(1)/*.glb > $$@
else
- python2 make_$(1).py
+ $$(PYTHON) make_$(1).py
$$(MAKE) -C work_$(1)
- python2 extract.py work_$(1)/*.glb > $$@
+ $$(PYTHON) extract.py work_$(1)/*.glb > $$@
endif
endef