aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz
diff options
context:
space:
mode:
authorLarry Doolittle <ldoolitt@recycle.lbl.gov>2017-07-31 17:01:55 -0700
committerClifford Wolf <clifford@clifford.at>2017-08-01 14:43:15 +0200
commitb3d35ccadc745851514abc7d7aa26f41532ac914 (patch)
treef40f1f87157ec0c917dfea14319fc15db0b1757c /icefuzz
parent607ee66cc1bdd37f8fc213b4b227cfebcd1d2c27 (diff)
downloadicestorm-b3d35ccadc745851514abc7d7aa26f41532ac914.tar.gz
icestorm-b3d35ccadc745851514abc7d7aa26f41532ac914.tar.bz2
icestorm-b3d35ccadc745851514abc7d7aa26f41532ac914.zip
Squelch trailing whitespace
Diffstat (limited to 'icefuzz')
-rw-r--r--icefuzz/fuzzconfig.py2
-rw-r--r--icefuzz/make_pll.py1
-rw-r--r--icefuzz/pinloc/pinloc-1k-qn84.sh3
-rw-r--r--icefuzz/tests/example_icestick.v2
-rw-r--r--icefuzz/tests/ioctrl_384.py2
-rw-r--r--icefuzz/tests/sb_ram40.v4
-rw-r--r--icefuzz/timings.py1
7 files changed, 6 insertions, 9 deletions
diff --git a/icefuzz/fuzzconfig.py b/icefuzz/fuzzconfig.py
index 1af5834..2e925ef 100644
--- a/icefuzz/fuzzconfig.py
+++ b/icefuzz/fuzzconfig.py
@@ -71,7 +71,7 @@ elif device_class == "5k":
#TODO(tannewt): Add 39, 40, 41 to this list. It causes placement failures for some reason.
gpins = "20 35 37 44".split()
-
+
def output_makefile(working_dir, fuzzname):
with open(working_dir + "/Makefile", "w") as f:
print("all: %s" % " ".join(["%s_%02d.bin" % (fuzzname, i) for i in range(num)]), file=f)
diff --git a/icefuzz/make_pll.py b/icefuzz/make_pll.py
index 757a222..704b3c0 100644
--- a/icefuzz/make_pll.py
+++ b/icefuzz/make_pll.py
@@ -11,7 +11,6 @@ def randbin(n):
for p in gpins:
if p in pins: pins.remove(p)
-
device_class = os.getenv("ICEDEVICE")
diff --git a/icefuzz/pinloc/pinloc-1k-qn84.sh b/icefuzz/pinloc/pinloc-1k-qn84.sh
index a55b736..f3ba8e7 100644
--- a/icefuzz/pinloc/pinloc-1k-qn84.sh
+++ b/icefuzz/pinloc/pinloc-1k-qn84.sh
@@ -7,8 +7,7 @@ pins="
A1 B1 A2 B2 A3 B3 A4 B4 A5 B5 A8 A9 B7 A10 B8 A11 B9 A12
A13 B10 B11 A14 B12 A16 B13 B14 A19 B15 A20 B17 A22 A23 B18 B19 A25 A26
B20 B21 A27 A29 B22 B23 A31 B24 A32 A33 A34 B26 A35 B27 A38 B29 A39 B30
- A40 B31 A41 A43 B32 A44 A45 B34 A46 B35 A47 B36 A48
-
+ A40 B31 A41 A43 B32 A44 A45 B34 A46 B35 A47 B36 A48
"
if [ $(echo $pins | wc -w) -ne 67 ]; then
diff --git a/icefuzz/tests/example_icestick.v b/icefuzz/tests/example_icestick.v
index 4635550..80924b6 100644
--- a/icefuzz/tests/example_icestick.v
+++ b/icefuzz/tests/example_icestick.v
@@ -24,6 +24,6 @@ module top (
always@(posedge clk)
counter <= counter + 1;
-
+
assign {LED1, LED2, LED3, LED4, LED5} = bin2gray(counter >> LOG2DELAY);
endmodule
diff --git a/icefuzz/tests/ioctrl_384.py b/icefuzz/tests/ioctrl_384.py
index ec8ddb8..e4c0739 100644
--- a/icefuzz/tests/ioctrl_384.py
+++ b/icefuzz/tests/ioctrl_384.py
@@ -19,7 +19,7 @@ for line in fileinput.input():
if line[0] == "IOB_1":
iob = (current_tile[0], current_tile[1], 1)
-if ren is None:
+if ren is None:
print("(%2d, %2d, %2d, ? , ? , ? )," % (iob[0], iob[1], iob[2]))
else:
print("(%2d, %2d, %2d, %2d, %2d, %2d)," % (iob[0], iob[1], iob[2], ren[0], ren[1], ren[2]))
diff --git a/icefuzz/tests/sb_ram40.v b/icefuzz/tests/sb_ram40.v
index 3516593..21fd781 100644
--- a/icefuzz/tests/sb_ram40.v
+++ b/icefuzz/tests/sb_ram40.v
@@ -1,6 +1,6 @@
// ICEDEV=hx8k-ct256 bash ../icecube.sh sb_ram40.v
-// ../../icebox/icebox_vlog.py -P sb_ram40.psb sb_ram40.txt
-// ../../icebox/icebox_explain.py -t '7 21' sb_ram40.txt
+// ../../icebox/icebox_vlog.py -P sb_ram40.psb sb_ram40.txt
+// ../../icebox/icebox_explain.py -t '7 21' sb_ram40.txt
module top (
input [10:0] WADDR,
diff --git a/icefuzz/timings.py b/icefuzz/timings.py
index 2e4cefb..009fd7d 100644
--- a/icefuzz/timings.py
+++ b/icefuzz/timings.py
@@ -435,4 +435,3 @@ if output_mode == "html":
print("<td>%s</td><td>%s</td><td>%s</td>" % tuple(entry[3].split(":")), end="")
print("</tr>")
print("</table>")
-