aboutsummaryrefslogtreecommitdiffstats
path: root/icetime
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-12-31 12:05:04 +0100
committerClifford Wolf <clifford@clifford.at>2015-12-31 12:05:04 +0100
commitb9e6d07e9ca9c4c6fb758e6886f43684948d70a7 (patch)
treef94bb5dcdc431a031ffde34d7307f10e86280547 /icetime
parent2d03b61380c3fec5f6d5b744c588eb76957db138 (diff)
downloadicestorm-b9e6d07e9ca9c4c6fb758e6886f43684948d70a7.tar.gz
icestorm-b9e6d07e9ca9c4c6fb758e6886f43684948d70a7.tar.bz2
icestorm-b9e6d07e9ca9c4c6fb758e6886f43684948d70a7.zip
Added config.mk, correct DESTDIR/PREFIX usage
Diffstat (limited to 'icetime')
-rw-r--r--icetime/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index c7f0c14..c98f40b 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -1,18 +1,17 @@
-# CXX = clang
+include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
-CC = $(CXX)
-DESTDIR = /usr/local
all: icetime
icetime: icetime.o
install: all
- cp icetime $(DESTDIR)/bin/icetime
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ cp icetime $(DESTDIR)$(PREFIX)/bin/icetime
uninstall:
- rm -f $(DESTDIR)/bin/icetime
+ rm -f $(DESTDIR)$(PREFIX)/bin/icetime
# View timing netlist: