aboutsummaryrefslogtreecommitdiffstats
path: root/icetime
diff options
context:
space:
mode:
Diffstat (limited to 'icetime')
-rw-r--r--icetime/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index c7f0c14..c98f40b 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -1,18 +1,17 @@
-# CXX = clang
+include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
-CC = $(CXX)
-DESTDIR = /usr/local
all: icetime
icetime: icetime.o
install: all
- cp icetime $(DESTDIR)/bin/icetime
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ cp icetime $(DESTDIR)$(PREFIX)/bin/icetime
uninstall:
- rm -f $(DESTDIR)/bin/icetime
+ rm -f $(DESTDIR)$(PREFIX)/bin/icetime
# View timing netlist: