aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rw-r--r--config.mk1
2 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5a95087..77e01fd 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,10 @@
-SUBDIRS = icebox icepack iceprog icemulti icepll icetime icebram
-
include config.mk
+SUBDIRS := icebox icepack icemulti icepll icebram icetime
+ifeq ($(ICEPROG),1)
+SUBDIRS += iceprog
+endif
+
all: $(addsuffix .all,$(SUBDIRS))
$(addsuffix .all,$(SUBDIRS)):
$(MAKE) -C $(basename $@) all
diff --git a/config.mk b/config.mk
index 3b8b675..c5ebc62 100644
--- a/config.mk
+++ b/config.mk
@@ -1,5 +1,6 @@
PREFIX ?= /usr/local
DEBUG ?= 0
+ICEPROG ?= 1
CXX ?= clang++
CC ?= clang