aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5a95087..77e01fd 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,10 @@
-SUBDIRS = icebox icepack iceprog icemulti icepll icetime icebram
-
include config.mk
+SUBDIRS := icebox icepack icemulti icepll icebram icetime
+ifeq ($(ICEPROG),1)
+SUBDIRS += iceprog
+endif
+
all: $(addsuffix .all,$(SUBDIRS))
$(addsuffix .all,$(SUBDIRS)):
$(MAKE) -C $(basename $@) all