aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shah <dave@ds0.me>2019-03-23 20:51:24 +0000
committerDavid Shah <dave@ds0.me>2019-03-23 20:51:24 +0000
commit32a683071758ee59d47e2c5cb29c87882993facd (patch)
tree497bc32ed44fd3fe54920265b931c758897534d6
parentd3ff834a116a92e134c423971807ed1f07f1138a (diff)
downloadnextpnr-tests-32a683071758ee59d47e2c5cb29c87882993facd.tar.gz
nextpnr-tests-32a683071758ee59d47e2c5cb29c87882993facd.tar.bz2
nextpnr-tests-32a683071758ee59d47e2c5cb29c87882993facd.zip
Allow waiving test success with a WAIVE file
-rw-r--r--ice40/regressions/Makefile8
-rw-r--r--ice40/regressions/issue0116/WAIVE0
2 files changed, 6 insertions, 2 deletions
diff --git a/ice40/regressions/Makefile b/ice40/regressions/Makefile
index 00243f8..2e961fe 100644
--- a/ice40/regressions/Makefile
+++ b/ice40/regressions/Makefile
@@ -23,8 +23,12 @@ endif
gzip -dk $<
$(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
- $(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1
- icebox_vlog $*.asc > $@
+ $(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1 || test -f $(dir $*)WAIVE
+ if [ ! -f $(dir $*)WAIVE ]; then \
+ icebox_vlog $*.asc > $@; \
+ else \
+ touch $@; \
+ fi
$(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
gzip -dk $*.json.gz
diff --git a/ice40/regressions/issue0116/WAIVE b/ice40/regressions/issue0116/WAIVE
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/ice40/regressions/issue0116/WAIVE