aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ice40/regressions/Makefile8
-rw-r--r--ice40/regressions/issue0116/WAIVE0
2 files changed, 6 insertions, 2 deletions
diff --git a/ice40/regressions/Makefile b/ice40/regressions/Makefile
index 00243f8..2e961fe 100644
--- a/ice40/regressions/Makefile
+++ b/ice40/regressions/Makefile
@@ -23,8 +23,12 @@ endif
gzip -dk $<
$(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
- $(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1
- icebox_vlog $*.asc > $@
+ $(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1 || test -f $(dir $*)WAIVE
+ if [ ! -f $(dir $*)WAIVE ]; then \
+ icebox_vlog $*.asc > $@; \
+ else \
+ touch $@; \
+ fi
$(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
gzip -dk $*.json.gz
diff --git a/ice40/regressions/issue0116/WAIVE b/ice40/regressions/issue0116/WAIVE
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/ice40/regressions/issue0116/WAIVE