aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-11 18:22:20 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-11 21:30:22 +0200
commiteb392f649ea544742849e50d920be677d09aa344 (patch)
treed3032358009998a515874bcc368c7cef5f5882ae /3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt
parentbe73894bea1c5719eccfad6b8c7e7ae44798a68a (diff)
downloadnextpnr-eb392f649ea544742849e50d920be677d09aa344.tar.gz
nextpnr-eb392f649ea544742849e50d920be677d09aa344.tar.bz2
nextpnr-eb392f649ea544742849e50d920be677d09aa344.zip
Added QtPropertyBrowser source
Diffstat (limited to '3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt')
-rw-r--r--3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt b/3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt
new file mode 100644
index 00000000..cafcb15d
--- /dev/null
+++ b/3rdparty/QtPropertyBrowser/examples/demo/CMakeLists.txt
@@ -0,0 +1,15 @@
+
+SET(example_name demo)
+
+SET(KIT_SRCS
+ main.cpp
+ )
+
+SET(KIT_resources
+ demo.qrc
+ )
+
+QT5_ADD_RESOURCES(KIT_QRC_SRCS ${KIT_resources})
+
+ADD_EXECUTABLE(${example_name} ${KIT_SRCS} ${KIT_QRC_SRCS})
+TARGET_LINK_LIBRARIES(${example_name} ${PROJECT_NAME})