aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-12 14:36:28 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-12 14:36:28 +0200
commit24618ee80029a2a22bfd288faba4b211aa6dac2a (patch)
tree051469ed61f314c97205e50503bb5189a612e8f2
parent9e06954edb1071b4ef2e7ebc525d8c6de42d0fc3 (diff)
downloadnextpnr-24618ee80029a2a22bfd288faba4b211aa6dac2a.tar.gz
nextpnr-24618ee80029a2a22bfd288faba4b211aa6dac2a.tar.bz2
nextpnr-24618ee80029a2a22bfd288faba4b211aa6dac2a.zip
Added python37 as well, fixes latest msys2 build and macOS
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbcdf67d..27265616 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,13 @@ if (BUILD_PYTHON)
endif ()
if (NOT Boost_PYTHON_FOUND)
+ find_package(Boost COMPONENTS python37 ${boost_libs})
+ if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )
+ set(Boost_PYTHON_FOUND TRUE)
+ endif ()
+ endif ()
+
+ if (NOT Boost_PYTHON_FOUND)
STRING(REGEX REPLACE "([0-9]+\\.[0-9]+).*" "\\1" gentoo_version ${PYTHONLIBS_VERSION_STRING})
find_package(Boost COMPONENTS python-${gentoo_version} ${boost_libs})
if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )