aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormyrtle <gatecat@ds0.me>2023-01-24 16:33:54 +0100
committerGitHub <noreply@github.com>2023-01-24 16:33:54 +0100
commitb9ed39bc1c8668c0d17b73515568b4fb01d0e9ca (patch)
treef2739edb8633f601a1529cc9cbd3b4a277ec3084
parent985c688bf6062553fafcfad386fa724b5e956302 (diff)
parent4c7e805f183ae74384737fb7caf7f7c13969bafb (diff)
downloadnextpnr-b9ed39bc1c8668c0d17b73515568b4fb01d0e9ca.tar.gz
nextpnr-b9ed39bc1c8668c0d17b73515568b4fb01d0e9ca.tar.bz2
nextpnr-b9ed39bc1c8668c0d17b73515568b4fb01d0e9ca.zip
Merge pull request #1081 from danc86/eigen-cmake-imported-target
use eigen as an IMPORTED target in CMake
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 269e90eb..4d15f724 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,8 +225,7 @@ include_directories(common/kernel/ common/place/ common/route/ json/ frontend/ 3
if(BUILD_HEAP)
find_package (Eigen3 REQUIRED NO_MODULE)
- include_directories(${EIGEN3_INCLUDE_DIRS})
- add_definitions(${EIGEN3_DEFINITIONS})
+ link_libraries(Eigen3::Eigen)
add_definitions(-DWITH_HEAP)
endif()