aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 269e90eb..4d15f724 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -225,8 +225,7 @@ include_directories(common/kernel/ common/place/ common/route/ json/ frontend/ 3
if(BUILD_HEAP)
find_package (Eigen3 REQUIRED NO_MODULE)
- include_directories(${EIGEN3_INCLUDE_DIRS})
- add_definitions(${EIGEN3_DEFINITIONS})
+ link_libraries(Eigen3::Eigen)
add_definitions(-DWITH_HEAP)
endif()