aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-03-12 11:23:10 +0000
committerGitHub <noreply@github.com>2021-03-12 11:23:10 +0000
commitbffaad477a541459e072339c28edf0087437c254 (patch)
tree605f47b65331ffda271d5b2353f317fff99f7f61
parentcc367d7e678f42f44ab029f2f3c372e4a09ed19d (diff)
parentbdf13ddcfbbdc2bd08270fbb72fec448f28e69c9 (diff)
downloadnextpnr-bffaad477a541459e072339c28edf0087437c254.tar.gz
nextpnr-bffaad477a541459e072339c28edf0087437c254.tar.bz2
nextpnr-bffaad477a541459e072339c28edf0087437c254.zip
Merge pull request #618 from YosysHQ/no-absl-on-wasi
Don't include Abseil if it is not used
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3df6a58..6ebc2e75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,7 +171,9 @@ if (NOT DEFINED CURRENT_GIT_VERSION)
)
endif()
-add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+if (NOT WASI)
+ add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+endif()
if (BUILD_TESTS)
add_subdirectory(3rdparty/googletest/googletest ${CMAKE_CURRENT_BINARY_DIR}/generated/3rdparty/googletest EXCLUDE_FROM_ALL)