aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/tests/counter
diff options
context:
space:
mode:
authorAlessandro Comodi <acomodi@antmicro.com>2021-04-07 12:07:10 +0200
committerAlessandro Comodi <acomodi@antmicro.com>2021-04-14 14:36:07 +0200
commitdfc9c3df8c016c26d8abe985d313b1bf81b4cc82 (patch)
tree9980d457fe97f3db67ba8dc16287bf9c607b0eb8 /fpga_interchange/examples/tests/counter
parent2912860c9788033a7501726e77bb4962b394280d (diff)
downloadnextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.tar.gz
nextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.tar.bz2
nextpnr-dfc9c3df8c016c26d8abe985d313b1bf81b4cc82.zip
interchange: add FASM generation target and clean-up tests
Signed-off-by: Alessandro Comodi <acomodi@antmicro.com>
Diffstat (limited to 'fpga_interchange/examples/tests/counter')
-rw-r--r--fpga_interchange/examples/tests/counter/CMakeLists.txt3
-rw-r--r--fpga_interchange/examples/tests/counter/zybo.xdc14
2 files changed, 16 insertions, 1 deletions
diff --git a/fpga_interchange/examples/tests/counter/CMakeLists.txt b/fpga_interchange/examples/tests/counter/CMakeLists.txt
index 2f1509c2..38c104ff 100644
--- a/fpga_interchange/examples/tests/counter/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/counter/CMakeLists.txt
@@ -1,8 +1,9 @@
add_interchange_group_test(
name counter
family ${family}
- board_list basys3 arty35t arty100t
+ board_list basys3 arty35t arty100t zybo
tcl run.tcl
sources counter.v
techmap ../../remap.v
+ output_fasm
)
diff --git a/fpga_interchange/examples/tests/counter/zybo.xdc b/fpga_interchange/examples/tests/counter/zybo.xdc
new file mode 100644
index 00000000..e7764d52
--- /dev/null
+++ b/fpga_interchange/examples/tests/counter/zybo.xdc
@@ -0,0 +1,14 @@
+# zybo board
+set_property PACKAGE_PIN K17 [get_ports clk]
+set_property PACKAGE_PIN K18 [get_ports rst]
+set_property PACKAGE_PIN M14 [get_ports io_led[4]]
+set_property PACKAGE_PIN M15 [get_ports io_led[5]]
+set_property PACKAGE_PIN G14 [get_ports io_led[6]]
+set_property PACKAGE_PIN D18 [get_ports io_led[7]]
+
+set_property IOSTANDARD LVCMOS33 [get_ports clk]
+set_property IOSTANDARD LVCMOS33 [get_ports rst]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[4]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[5]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[6]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[7]]