aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/tests/ff
diff options
context:
space:
mode:
Diffstat (limited to 'fpga_interchange/examples/tests/ff')
-rw-r--r--fpga_interchange/examples/tests/ff/CMakeLists.txt19
-rw-r--r--fpga_interchange/examples/tests/ff/arty100t.xdc (renamed from fpga_interchange/examples/tests/ff/ff_arty.xdc)8
-rw-r--r--fpga_interchange/examples/tests/ff/arty35t.xdc9
-rw-r--r--fpga_interchange/examples/tests/ff/basys3.xdc (renamed from fpga_interchange/examples/tests/ff/ff_basys3.xdc)0
4 files changed, 17 insertions, 19 deletions
diff --git a/fpga_interchange/examples/tests/ff/CMakeLists.txt b/fpga_interchange/examples/tests/ff/CMakeLists.txt
index ccf16d44..e119b7c3 100644
--- a/fpga_interchange/examples/tests/ff/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/ff/CMakeLists.txt
@@ -1,19 +1,8 @@
-add_interchange_test(
- name ff_basys3
+add_interchange_group_test(
+ name ff
family ${family}
- device xc7a35t
- package cpg236
+ board_list basys3 arty35t arty100t
tcl run.tcl
- xdc ff_basys3.xdc
- sources ff.v
-)
-
-add_interchange_test(
- name ff_arty
- family ${family}
- device xc7a35t
- package csg324
- tcl run.tcl
- xdc ff_arty.xdc
sources ff.v
+ output_fasm
)
diff --git a/fpga_interchange/examples/tests/ff/ff_arty.xdc b/fpga_interchange/examples/tests/ff/arty100t.xdc
index 3c132f1d..29456f2a 100644
--- a/fpga_interchange/examples/tests/ff/ff_arty.xdc
+++ b/fpga_interchange/examples/tests/ff/arty100t.xdc
@@ -1,7 +1,7 @@
-set_property PACKAGE_PIN P17 [get_ports clk]
-set_property PACKAGE_PIN N15 [get_ports d]
-set_property PACKAGE_PIN N16 [get_ports r]
-set_property PACKAGE_PIN M17 [get_ports q]
+set_property PACKAGE_PIN E3 [get_ports clk]
+set_property PACKAGE_PIN A8 [get_ports d]
+set_property PACKAGE_PIN D9 [get_ports r]
+set_property PACKAGE_PIN H5 [get_ports q]
set_property IOSTANDARD LVCMOS33 [get_ports clk]
set_property IOSTANDARD LVCMOS33 [get_ports d]
diff --git a/fpga_interchange/examples/tests/ff/arty35t.xdc b/fpga_interchange/examples/tests/ff/arty35t.xdc
new file mode 100644
index 00000000..29456f2a
--- /dev/null
+++ b/fpga_interchange/examples/tests/ff/arty35t.xdc
@@ -0,0 +1,9 @@
+set_property PACKAGE_PIN E3 [get_ports clk]
+set_property PACKAGE_PIN A8 [get_ports d]
+set_property PACKAGE_PIN D9 [get_ports r]
+set_property PACKAGE_PIN H5 [get_ports q]
+
+set_property IOSTANDARD LVCMOS33 [get_ports clk]
+set_property IOSTANDARD LVCMOS33 [get_ports d]
+set_property IOSTANDARD LVCMOS33 [get_ports r]
+set_property IOSTANDARD LVCMOS33 [get_ports q]
diff --git a/fpga_interchange/examples/tests/ff/ff_basys3.xdc b/fpga_interchange/examples/tests/ff/basys3.xdc
index ef65112a..ef65112a 100644
--- a/fpga_interchange/examples/tests/ff/ff_basys3.xdc
+++ b/fpga_interchange/examples/tests/ff/basys3.xdc