aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2021-10-20 13:08:08 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2021-10-20 13:08:08 +0200
commitbf79ff5927d3b31faf0099870445e36211878096 (patch)
tree7065c4fb6365e7d5fe72e498427f2c57931fe07c
parent150ce305f9d51ec92380eb544e64af3770be5bdb (diff)
downloadyosys-bf79ff5927d3b31faf0099870445e36211878096.tar.gz
yosys-bf79ff5927d3b31faf0099870445e36211878096.tar.bz2
yosys-bf79ff5927d3b31faf0099870445e36211878096.zip
If verific have vhdl lib it is required by other libs
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4140c16f9..d1795f813 100644
--- a/Makefile
+++ b/Makefile
@@ -504,6 +504,10 @@ VERIFIC_COMPONENTS ?= verilog database util containers hier_tree
ifneq ($(DISABLE_VERIFIC_VHDL),1)
VERIFIC_COMPONENTS += vhdl
CXXFLAGS += -DVERIFIC_VHDL_SUPPORT
+else
+ifneq ($(wildcard $(VERIFIC_DIR)/vhdl),)
+VERIFIC_COMPONENTS += vhdl
+endif
endif
ifneq ($(DISABLE_VERIFIC_EXTENSIONS),1)
VERIFIC_COMPONENTS += extensions