aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2010-12-10 18:59:58 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2010-12-10 18:59:58 +0000
commit16c44de3e98304a07ab427be772bd4d614634c0c (patch)
tree6b22ba8bc00c6fe254dc1f50b976a34587def713 /target/linux/brcm63xx/image
parentb0b20ac0a3968489c1c5117f91161447f09d2e3a (diff)
downloadmaster-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.tar.gz
master-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.tar.bz2
master-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.zip
[brcm63xx] Fixed Comtrend CT536_CT5621 board settings. These boards are based on the 96348GW-11 reference design but have different GPIOs therefore we use the board fixups now availabed (thanks the patches by Jonas Gorski) to create a separate board entry for these boards and leave the reference design with reference GPIOs. Also these boards only have enet1 (no enet0) so we set that in the board definition, and use a defconfig for a single interface network.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24442 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 25c9b36a49..b34c7eb5dc 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -128,6 +128,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW,6348,96348GW-bc221,,--layoutver 5)
$(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
$(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
+ $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-gen)
+ $(call Image/Build/CFE,$(1),96348GW-10,6348,96348GW-10-gen)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -152,7 +154,7 @@ define Image/Build
# Neufbox4
$(call Image/Build/CFE,$(1),96358VW,6358,NEUFBOX4,OpenWRT-$(REVISION))
# Comtrend 536, 5621
- $(call Image/Build/CFE,$(1),96348GW-11,6348,CT536_CT5621)
+ $(call Image/Build/CFEFIXUP,$(1),96348GW-11,6348,CT536_CT5621)
# Davolink DV201AMR
$(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
# USR 9108