aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-12-11 23:17:56 +0000
committerMichael Büsch <mb@bu3sch.de>2008-12-11 23:17:56 +0000
commitd565bb20de4a9dec01f2f4c0f62be55eb61435a9 (patch)
tree92a69a57cf62fe9a5efb075279904a3f01721334 /target
parent1e6f045dc5ed15f048891d420fe2c088b3798123 (diff)
downloadmaster-187ad058-d565bb20de4a9dec01f2f4c0f62be55eb61435a9.tar.gz
master-187ad058-d565bb20de4a9dec01f2f4c0f62be55eb61435a9.tar.bz2
master-187ad058-d565bb20de4a9dec01f2f4c0f62be55eb61435a9.zip
Build the root fs.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13608 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/openmoko/Makefile2
-rw-r--r--target/linux/openmoko/image/Makefile9
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/openmoko/Makefile b/target/linux/openmoko/Makefile
index 22bfaea57f..e56ba1635f 100644
--- a/target/linux/openmoko/Makefile
+++ b/target/linux/openmoko/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=openmoko
BOARDNAME:=Openmoko
-FEATURES:=squashfs usb
+FEATURES:=usb
LINUX_VERSION:=2.6.24.7
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
index 20f17590f3..34ca44b701 100644
--- a/target/linux/openmoko/image/Makefile
+++ b/target/linux/openmoko/image/Makefile
@@ -5,9 +5,17 @@
# See /LICENSE for more information.
#
+JFFS2_BLOCKSIZE := 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/mkfs/jffs2/sub
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 --pad --little-endian --pagesize=0x800 --no-cleanmarkers -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(1) -d $(TARGET_DIR)
+ $(call add_jffs2_mark,$(KDIR)/root.jffs2-$(1))
+ $(call Image/Build,jffs2-$(1))
+endef
+
define Build/Clean
endef
@@ -23,6 +31,7 @@ define Image/BuildKernel
endef
define Image/Build
+ cp $(KDIR)/root.jffs2-128k $(BIN_DIR)/openwrt-$(BOARD)-rootfs
endef
$(eval $(call BuildImage))