aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/patches/.svn/text-base
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/patches/.svn/text-base')
-rw-r--r--tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base20
-rw-r--r--tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base15
-rw-r--r--tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base16
3 files changed, 51 insertions, 0 deletions
diff --git a/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base b/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base
new file mode 100644
index 0000000..47c0ae8
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/000-relocatable.patch.svn-base
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1919,6 +1919,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+
+ yacc:
+ $(AM_V_GEN)echo '#! /bin/sh' >$@
++ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ $(AM_V_at)chmod a+x $@
+
diff --git a/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base b/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base
new file mode 100644
index 0000000..d2dfcad
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/010-intl-stub-compat.patch.svn-base
@@ -0,0 +1,15 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -60,9 +60,9 @@ main (int argc, char *argv[])
+ {
+ set_program_name (argv[0]);
+ setlocale (LC_ALL, "");
+- (void) bindtextdomain (PACKAGE, LOCALEDIR);
+- (void) bindtextdomain ("bison-runtime", LOCALEDIR);
+- (void) textdomain (PACKAGE);
++ bindtextdomain (PACKAGE, LOCALEDIR);
++ bindtextdomain ("bison-runtime", LOCALEDIR);
++ textdomain (PACKAGE);
+
+ {
+ char const *cp = getenv ("LC_CTYPE");
diff --git a/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base b/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
new file mode 100644
index 0000000..169bfd6
--- /dev/null
+++ b/tools/bison/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
@@ -0,0 +1,16 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -704,13 +704,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+ # endif
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning; besides, C11
+- removed it. */
+-#undef gets
+-#if HAVE_RAW_DECL_GETS
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@