aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 00:17:07 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-27 00:25:12 +0200
commit3fdb08681b36537f430dc55743c90154790554ce (patch)
tree97cf82f34d47731e9427ca6ddec0fc712a8b32f4
parentad697aabc30875bd078275f59e69667279aa075d (diff)
downloadupstream-3fdb08681b36537f430dc55743c90154790554ce.tar.gz
upstream-3fdb08681b36537f430dc55743c90154790554ce.tar.bz2
upstream-3fdb08681b36537f430dc55743c90154790554ce.zip
mvebu: tidy up support for GL.iNet GL-MV1000
This fixes a bunch of cosmetic issues with GL.iNet GL-MV1000: - apply alphabetic sorting in multiple files - use armada-3720 prefix for DTS like for other devices - fix vendor capitalization for model in DTSes - remove trivial comment in DTS files - use DEVICE_VENDOR/DEVICE_MODEL - remove redundant SUPPORTED_DEVICES - use SOC instead of DEVICE_DTS - remove empty line at EOF Fixes: 050c24f05c85 ("mvebu: add support for GL.iNet GL-MV1000") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/boot/uboot-envtools/files/mvebu6
-rwxr-xr-xtarget/linux/mvebu/cortexa53/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts (renamed from target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts)5
-rw-r--r--target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts (renamed from target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts)5
-rw-r--r--target/linux/mvebu/image/cortexa53.mk17
5 files changed, 15 insertions, 22 deletions
diff --git a/package/boot/uboot-envtools/files/mvebu b/package/boot/uboot-envtools/files/mvebu
index b883f0aa8c..10f31b05a1 100644
--- a/package/boot/uboot-envtools/files/mvebu
+++ b/package/boot/uboot-envtools/files/mvebu
@@ -17,6 +17,9 @@ case "$board" in
cznic,turris-omnia)
ubootenv_add_uci_config "/dev/mtd0" "0xC0000" "0x10000" "0x40000"
;;
+glinet,gl-mv1000)
+ ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x8000" "0x8000" "1"
+ ;;
globalscale,espressobin|\
globalscale,espressobin-emmc|\
globalscale,espressobin-v7|\
@@ -24,9 +27,6 @@ globalscale,espressobin-v7-emmc|\
marvell,armada8040-mcbin)
ubootenv_add_uci_config "/dev/mtd0" "0x3f0000" "0x10000" "0x10000" "1"
;;
-glinet,gl-mv1000)
- ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x8000" "0x8000" "1"
- ;;
linksys,caiman|\
linksys,cobra|\
linksys,shelby)
diff --git a/target/linux/mvebu/cortexa53/base-files/etc/board.d/02_network b/target/linux/mvebu/cortexa53/base-files/etc/board.d/02_network
index 9b1d97d921..0a2a2b144c 100755
--- a/target/linux/mvebu/cortexa53/base-files/etc/board.d/02_network
+++ b/target/linux/mvebu/cortexa53/base-files/etc/board.d/02_network
@@ -11,11 +11,11 @@ board_config_update
board=$(board_name)
case "$board" in
+glinet,gl-mv1000|\
globalscale,espressobin|\
globalscale,espressobin-emmc|\
globalscale,espressobin-v7|\
-globalscale,espressobin-v7-emmc|\
-glinet,gl-mv1000)
+globalscale,espressobin-v7-emmc)
ucidef_set_interfaces_lan_wan "lan0 lan1" "wan"
;;
marvell,armada-3720-db|\
diff --git a/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts b/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts
index 9d7963c5b7..d1a966f4f8 100644
--- a/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts
+++ b/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts
@@ -1,14 +1,11 @@
// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
-/*
- * Device Tree file for GL.iNet GL-MV1000
- */
/dts-v1/;
#include <dt-bindings/gpio/gpio.h>
#include "armada-372x.dtsi"
/ {
- model = "GL.inet GL-MV1000";
+ model = "GL.iNet GL-MV1000";
compatible = "glinet,gl-mv1000", "marvell,armada3720";
chosen {
diff --git a/target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts b/target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts
index 9d7963c5b7..d1a966f4f8 100644
--- a/target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-gl-mv1000.dts
+++ b/target/linux/mvebu/files-5.4/arch/arm64/boot/dts/marvell/armada-3720-gl-mv1000.dts
@@ -1,14 +1,11 @@
// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
-/*
- * Device Tree file for GL.iNet GL-MV1000
- */
/dts-v1/;
#include <dt-bindings/gpio/gpio.h>
#include "armada-372x.dtsi"
/ {
- model = "GL.inet GL-MV1000";
+ model = "GL.iNet GL-MV1000";
compatible = "glinet,gl-mv1000", "marvell,armada3720";
chosen {
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index 1436c1bd23..ff8f2c0930 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -1,3 +1,11 @@
+define Device/glinet_gl-mv1000
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-MV1000
+ SOC := armada-3720
+endef
+TARGET_DEVICES += glinet_gl-mv1000
+
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -69,12 +77,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-define Device/glinet_gl-mv1000
- $(call Device/Default-arm64)
- DEVICE_TITLE := GL.iNet GL-MV1000
- DEVICE_DTS := armada-gl-mv1000
- SUPPORTED_DEVICES := glinet,gl-mv1000
-endef
-TARGET_DEVICES += glinet_gl-mv1000
-