diff options
author | Felix Fietkau <nbd@nbd.name> | 2017-01-22 13:47:24 +0100 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2017-01-22 13:47:40 +0100 |
commit | 664918d891f3d29f09c15b0abe6616bbfdb2d0c6 (patch) | |
tree | bae6a57fd505763ff398840008e2d8d6dba51c74 | |
parent | 2990a21058243b067bb56fed36ee69205595993e (diff) | |
download | upstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.tar.gz upstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.tar.bz2 upstream-664918d891f3d29f09c15b0abe6616bbfdb2d0c6.zip |
Revert "build: always run package/cleanup before package/compile"
This reverts commit 2990a21058243b067bb56fed36ee69205595993e.
This introduces a race condition, let's fix this in buildbot instead.
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | package/Makefile | 3 |
2 files changed, 2 insertions, 3 deletions
@@ -41,7 +41,7 @@ else $(toolchain/stamp-compile): $(tools/stamp-compile) $(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared -$(package/stamp-compile): $(target/stamp-compile) +$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-install): $(package/stamp-compile) $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check) diff --git a/package/Makefile b/package/Makefile index b5e4bfa12b..6929c479a2 100644 --- a/package/Makefile +++ b/package/Makefile @@ -49,8 +49,6 @@ PACKAGE_INSTALL_FILES:= \ $(curdir)/cleanup: $(TMP_DIR)/.build rm -rf $(STAGING_DIR_ROOT) -$(curdir)/compile: $(curdir)/cleanup - $(curdir)/merge: rm -rf $(PACKAGE_DIR_ALL) mkdir -p $(PACKAGE_DIR_ALL) @@ -100,6 +98,7 @@ $(curdir)/preconfig: $(curdir)/flags-install:= -j1 $(eval $(call stampfile,$(curdir),package,prereq,.config)) +$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build)) |