aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-01 19:43:54 +0200
committerPetr Štetiar <ynezz@true.cz>2019-05-15 13:34:23 +0200
commite7756974aa051c927c034d87b1c6611861899354 (patch)
treebda28c70f3495982fdf800969e868005a972d949
parenteb7eed416bc09eab5edb11f028eff09777d4989a (diff)
downloadupstream-e7756974aa051c927c034d87b1c6611861899354.tar.gz
upstream-e7756974aa051c927c034d87b1c6611861899354.tar.bz2
upstream-e7756974aa051c927c034d87b1c6611861899354.zip
tegra: add vendor string to device name
for better identification. Also create SUPPORTED_DEVICES string from it which corresponds to dts compatible string. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
-rw-r--r--package/boot/uboot-tegra/Makefile2
-rw-r--r--target/linux/tegra/image/Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/package/boot/uboot-tegra/Makefile b/package/boot/uboot-tegra/Makefile
index a42d9cfc27..4b9f7876f8 100644
--- a/package/boot/uboot-tegra/Makefile
+++ b/package/boot/uboot-tegra/Makefile
@@ -23,7 +23,7 @@ endef
define U-Boot/trimslice
NAME := CompuLab TrimSlice
- BUILD_DEVICES := trimslice
+ BUILD_DEVICES := compulab_trimslice
UBOOT_IMAGE := trimslice-mmc.img trimslice-spi.img
SOC := tegra20
VENDOR := compulab
diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index 706cc65d92..c1aa81bedd 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -44,16 +44,16 @@ define Device/Default
KERNEL_NAME := zImage
KERNEL := kernel-bin
PROFILES := Default
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
endef
-define Device/trimslice
+define Device/compulab_trimslice
DEVICE_TITLE := CompuLab TrimSlice
DEVICE_DTS := tegra20-trimslice
DEVICE_PACKAGES := kmod-r8169 kmod-rt2800-usb kmod-rtc-em3027 \
kmod-usb-storage wpad-mini
- SUPPORTED_DEVICES := compulab,trimslice
UBOOT := trimslice-mmc
endef
-TARGET_DEVICES += trimslice
+TARGET_DEVICES += compulab_trimslice
$(eval $(call BuildImage))