aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
commit2a4a0c2bcccdd56d23bd00aabb457da21876eb3a (patch)
treeb0fe32c81da46cd261869152678f446604d28a96 /package/madwifi/Makefile
parentd07eb95838190f3bcd7f0528e519e988be5735af (diff)
downloadupstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.gz
upstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.bz2
upstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.zip
explicitely disable a bunch of package on ar7 until we properly detect pci & usb support at configure time
SVN-Revision: 10839
Diffstat (limited to 'package/madwifi/Makefile')
-rw-r--r--package/madwifi/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index f2fdac7b9d..d502e33f59 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -59,7 +59,7 @@ else
endif
# XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_uml),)
+ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
BUS:=
endif
@@ -108,7 +108,7 @@ define KernelPackage/madwifi
SUBMENU:=Wireless Drivers
TITLE:=Driver for Atheros wireless chipsets
URL:=http://madwifi.org/
- DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
+ DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
FILES:=$(MADWIFI_FILES)
AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
endef