aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2020-06-03 21:15:09 +0200
committerPetr Štetiar <ynezz@true.cz>2020-07-09 10:28:40 +0200
commit361c670a468cac8def368ed95487c72cfdb4a3fa (patch)
treef05ae51c43ebd9bafe7c7db0e8d3d6f3ba2fe276 /target/linux/ath79/image
parent358aec77756d6bf850a533272f2685a45220dc0c (diff)
downloadupstream-361c670a468cac8def368ed95487c72cfdb4a3fa.tar.gz
upstream-361c670a468cac8def368ed95487c72cfdb4a3fa.tar.bz2
upstream-361c670a468cac8def368ed95487c72cfdb4a3fa.zip
ath79: add support for D-Link DAP-1330/DAP-1365 A1
Port device support for DAP-1330 from the ar71xx target to ath79. Additionally, images are generated for the European through-socket case variant DAP-1365. Both devices run the same vendor firmware, the only difference being the DAP_SIGNATURE field in the factory header. The vendor's Web UI will display a model string stored in the flash. Specifications: * QCA9533, 8 MiB Flash, 64 MiB RAM * One Ethernet Port (10/100) * Wall-plug style case (DAP-1365 with additional socket) * LED bargraph RSSI indicator Installation: * Web UI: http://192.168.0.50 (or different address obtained via DHCP) There is no password set by default * Recovery Web UI: Keep reset button pressed during power-on until LED starts flashing red, upgrade via http://192.168.0.50 * Some modern browsers may have problems flashing via the Web UI, if this occurs consider booting to recovery mode and flashing via: curl -F \ files=@openwrt-ath79-generic-dlink_dap-1330-a1-squashfs-factory.bin \ http://192.168.0.50/cgi/index The device will use the same MAC address for both wired and wireless interfaces, however it is stored at two different locations in the flash. Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 46a8705b85..8dc16983e1 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -565,6 +565,33 @@ define Device/devolo_magic-2-wifi
endef
TARGET_DEVICES += devolo_magic-2-wifi
+define Device/dlink_dap-13xx
+ SOC := qca9533
+ DEVICE_VENDOR := D-Link
+ DEVICE_PACKAGES += rssileds
+ IMAGE_SIZE := 7936k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | mkdapimg2 0xE0000
+endef
+
+define Device/dlink_dap-1330-a1
+ $(Device/dlink_dap-13xx)
+ DEVICE_MODEL := DAP-1330
+ DEVICE_VARIANT := A1
+ DAP_SIGNATURE := HONEYBEE-FIRMWARE-DAP-1330
+ SUPPORTED_DEVICES += dap-1330-a1
+endef
+TARGET_DEVICES += dlink_dap-1330-a1
+
+define Device/dlink_dap-1365-a1
+ $(Device/dlink_dap-13xx)
+ DEVICE_MODEL := DAP-1365
+ DEVICE_VARIANT := A1
+ DAP_SIGNATURE := HONEYBEE-FIRMWARE-DAP-1365
+endef
+TARGET_DEVICES += dlink_dap-1365-a1
+
define Device/dlink_dap-2695-a1
SOC := qca9558
DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct