aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-18 13:49:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-21 11:34:55 +0200
commiteb531337a779a48a2d17bc66f0d222325d6c1563 (patch)
tree4d114cd671dadb319150d037c7a9b3a715d0bae8 /target/linux/ath79/image
parent14ae431c836d81830a510ebed0937d862491a058 (diff)
downloadupstream-eb531337a779a48a2d17bc66f0d222325d6c1563.tar.gz
upstream-eb531337a779a48a2d17bc66f0d222325d6c1563.tar.bz2
upstream-eb531337a779a48a2d17bc66f0d222325d6c1563.zip
ath79: add support for TP-Link TL-WR710N v2.1
This adds support for the TP-Link TL-WR710N v2.1. It is basically a re-issue of the v1.2. Specifications: SoC: Atheros AR9331 CPU: 400 MHz Flash: 8 MiB RAM: 32 MiB WiFi: 2.4 GHz b/g/n Ethernet: 2x 100M ports USB: 1x 2.0 The only difference from the v1 is the TP-Link hardware ID/revision. Attention: The TL-WR710N v2.0 (!) has only 4 MB flash and cannot be flashed with this image. It has a different TPLINK_HWREV, so accidental flashing of the factory image should be impossible without additional measures. Unfortunately, the v2.0 in ar71xx has the same board name, so sysupgrade from ar71xx v2.0 into ath79 v1/v2.1 will not be prevented, but will brick the device. Flashing instruction: Upload the factory image via the OEM firmware GUI upgrade mechanism. Further notes: To make implementation easier if somebody desires to port the 4M v2.0, this already creates two DTSI files. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Fabian Eppig <fabian@eppig.de>
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index fdc94b738a..7128d853f8 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -625,6 +625,18 @@ define Device/tplink_tl-wr710n-v1
endef
TARGET_DEVICES += tplink_tl-wr710n-v1
+define Device/tplink_tl-wr710n-v2.1
+ $(Device/tplink-8mlzma)
+ SOC := ar9331
+ DEVICE_MODEL := TL-WR710N
+ DEVICE_VARIANT := v2.1
+ DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x07100002
+ TPLINK_HWREV := 0x2
+ SUPPORTED_DEVICES += tl-wr710n
+endef
+TARGET_DEVICES += tplink_tl-wr710n-v2.1
+
define Device/tplink_tl-wr810n-v1
$(Device/tplink-8mlzma)
SOC := qca9531