aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-14 00:23:51 +0100
committerDavid Bauer <mail@david-bauer.net>2021-02-18 01:15:33 +0100
commitc9137e2ddf97ede1db399dc38acff26feb48ba7e (patch)
tree474c00a369fd53d2bf4e9067c2adc70220f55b2b /target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
parentf323dec4f866d9ea75eae11c6762d0144d100628 (diff)
downloadupstream-c9137e2ddf97ede1db399dc38acff26feb48ba7e.tar.gz
upstream-c9137e2ddf97ede1db399dc38acff26feb48ba7e.tar.bz2
upstream-c9137e2ddf97ede1db399dc38acff26feb48ba7e.zip
mediatek: add Ubiquiti LED driver
Add a driver for controlling the RGB LED via Ubiquitis own "LEDBAR" LED controller based on the Holtek HT32F52241 MCU. This driver is initially used by the Ubiquiti UniFi 6 LR, however judging from FCC pictures the MCU is also found on the U6-Mesh as well as the U6-Extender. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch')
-rw-r--r--target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch b/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
new file mode 100644
index 0000000000..c971b9b4ca
--- /dev/null
+++ b/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
@@ -0,0 +1,29 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -823,6 +823,16 @@ config LEDS_LM36274
+ Say Y to enable the LM36274 LED driver for TI LMU devices.
+ This supports the LED device LM36274.
+
++config LEDS_UBNT_LEDBAR
++ tristate "LED support for Ubiquiti UniFi 6 LR"
++ depends on LEDS_CLASS && I2C && OF
++ help
++ This option enables support for the Ubiquiti LEDBAR
++ LED driver.
++
++ To compile this driver as a module, choose M here: the module
++ will be called leds-ubnt-ledbar.
++
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -85,6 +85,7 @@ obj-$(CONFIG_LEDS_LM3601X) += leds-lm36
+ obj-$(CONFIG_LEDS_TI_LMU_COMMON) += leds-ti-lmu-common.o
+ obj-$(CONFIG_LEDS_LM3697) += leds-lm3697.o
+ obj-$(CONFIG_LEDS_LM36274) += leds-lm36274.o
++obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o