aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch')
-rw-r--r--target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch b/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
new file mode 100644
index 0000000000..c971b9b4ca
--- /dev/null
+++ b/target/linux/mediatek/patches-5.4/1021-ubnt-ledbar-driver.patch
@@ -0,0 +1,29 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -823,6 +823,16 @@ config LEDS_LM36274
+ Say Y to enable the LM36274 LED driver for TI LMU devices.
+ This supports the LED device LM36274.
+
++config LEDS_UBNT_LEDBAR
++ tristate "LED support for Ubiquiti UniFi 6 LR"
++ depends on LEDS_CLASS && I2C && OF
++ help
++ This option enables support for the Ubiquiti LEDBAR
++ LED driver.
++
++ To compile this driver as a module, choose M here: the module
++ will be called leds-ubnt-ledbar.
++
+ comment "LED Triggers"
+ source "drivers/leds/trigger/Kconfig"
+
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -85,6 +85,7 @@ obj-$(CONFIG_LEDS_LM3601X) += leds-lm36
+ obj-$(CONFIG_LEDS_TI_LMU_COMMON) += leds-ti-lmu-common.o
+ obj-$(CONFIG_LEDS_LM3697) += leds-lm3697.o
+ obj-$(CONFIG_LEDS_LM36274) += leds-lm36274.o
++obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o