aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortex-a72.mk
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:33 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commita39d2a8053a656f75ffdd914d433e33fef86ee3e (patch)
tree44845ba67620d4b2e8ee9e55241a62e034bb8065 /target/linux/mvebu/image/cortex-a72.mk
parent30b5554411192415ce70f16c1b48b11ce013bbf2 (diff)
downloadupstream-a39d2a8053a656f75ffdd914d433e33fef86ee3e.tar.gz
upstream-a39d2a8053a656f75ffdd914d433e33fef86ee3e.tar.bz2
upstream-a39d2a8053a656f75ffdd914d433e33fef86ee3e.zip
mvebu: align device names to vendor_device format
Add vendors in device names and also rename few device names, for easier identyfying potential firmware to flash. The vendor and device string is mainly derived from model/compatipble string in dts from particular device, but since not all devices are well described, some of the renames follow marketing names. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/cortex-a72.mk')
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index 824f6b5d0f..b1069b1f0b 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -1,30 +1,30 @@
ifeq ($(SUBTARGET),cortexa72)
-define Device/armada-macchiatobin
+define Device/marvell_macchiatobin
$(call Device/Default-arm64)
DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
DEVICE_DTS := armada-8040-mcbin
SUPPORTED_DEVICES := marvell,armada8040-mcbin
endef
-TARGET_DEVICES += armada-macchiatobin
+TARGET_DEVICES += marvell_macchiatobin
-define Device/armada-8040-db
+define Device/marvell_armada8040-db
$(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 8040 DB board
DEVICE_DTS := armada-8040-db
IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
SUPPORTED_DEVICES := marvell,armada8040-db
endef
-TARGET_DEVICES += armada-8040-db
+TARGET_DEVICES += marvell_armada8040-db
-define Device/armada-7040-db
+define Device/marvell_armada7040-db
$(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 7040 DB board
DEVICE_DTS := armada-7040-db
IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
SUPPORTED_DEVICES := marvell,armada7040-db
endef
-TARGET_DEVICES += armada-7040-db
+TARGET_DEVICES += marvell_armada7040-db
endif