aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa9.mk
diff options
context:
space:
mode:
authorAlberto Bursi <bobafetthotmail@gmail.com>2020-07-12 15:35:54 +0200
committerPetr Štetiar <ynezz@true.cz>2020-07-17 11:00:33 +0200
commit480003e9eb0dac5dba032fbce64c35c34ff386ce (patch)
tree5564d575909f1a7f138edce3f32fd33ae0e32652 /target/linux/mvebu/image/cortexa9.mk
parentf013cc4b26890bd71bf8fe4010beae0cbfd16d10 (diff)
downloadupstream-480003e9eb0dac5dba032fbce64c35c34ff386ce.tar.gz
upstream-480003e9eb0dac5dba032fbce64c35c34ff386ce.tar.bz2
upstream-480003e9eb0dac5dba032fbce64c35c34ff386ce.zip
mvebu: add Kobol Helios 4 device
The Helios 4 is a NAS from Kobol that is powered by an Armada 38x MicroSOM from Solidrun, similarly to Clearfog. This device has: -Armada 38x CPU (dual core ARMv7 1.6 Ghz) -2 GB of ECC RAM -Gigabit ethernet (Marvell) -2x USB 3.0 ports -4x Sata 3.0 ports -i2c header (J9 |>GND|SDA|SCL|VCC) -2x 3-pin fan headers with PWM -micro-usb port is a TTL/UART to USB converter connected to TTL -MicroSD card slot -System, 4xSata and 1xUSB LEDs NOT WORKING: fan control Fan Control requires a kernel patch that is available in the Armbian project (the "default firmware" of this device) and named mvebu-gpio-remove-hardcoded -timer-assignment This patch isn't acceptable by OpenWrt, it should be upstreamed. I also have that patch in my own local OpenWrt builds, in case you want a more clean and less confusing patch for upstreaming. To install, write the disk image on a micro SD card with dd or win32 disk imager, insert the card in the slot. Check that the dip switch battery for boot selection is as follows Switch 1 and 2 down/off, switches 3, 4, 5 up/on. Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
Diffstat (limited to 'target/linux/mvebu/image/cortexa9.mk')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 7f0a2fe697..5f32367431 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -51,6 +51,20 @@ define Device/globalscale_mirabox
endef
TARGET_DEVICES += globalscale_mirabox
+define Device/kobol_helios4
+ DEVICE_VENDOR := Kobol
+ DEVICE_MODEL := Helios4
+ KERNEL_INSTALL := 1
+ KERNEL := kernel-bin
+ DEVICE_PACKAGES := mkf2fs e2fsprogs partx-utils
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ SOC := armada-388
+ UBOOT := helios4-u-boot-spl.kwb
+ BOOT_SCRIPT := clearfog
+endef
+TARGET_DEVICES += kobol_helios4
+
define Device/linksys
$(Device/NAND-128K)
DEVICE_VENDOR := Linksys