aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:11 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:18:07 +0100
commit0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (patch)
treeca8b22af59a20a90289901cbe41cbb491141b549 /target/linux/mvebu/image
parentb99b60b2f164cb62212dd9812ddc8ce8df9f90a9 (diff)
downloadupstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.gz
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.bz2
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.zip
mvebu: move subtarget image Makefile switch to parent Makefile
This moves the if conditions for choosing which image Makefiles are used to the parent image/Makefile. It seems more convenient to have "codeflow" in the parent while the subtarget-specific files only contain the definitions. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile8
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk4
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk4
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk4
4 files changed, 8 insertions, 12 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index ce1344a547..6dd7bde7ae 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -116,8 +116,16 @@ define Device/NAND-512K
PAGESIZE := 4096
endef
+ifeq ($(SUBTARGET),cortexa9)
include cortex-a9.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa72)
include cortex-a72.mk
+endif
$(eval $(call BuildImage))
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index f5313429af..e58a3c42b9 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa53)
-
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -73,5 +71,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-endif
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index 5e619804e8..6abee2d8b9 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa72)
-
define Device/marvell_macchiatobin
$(call Device/Default-arm64)
DEVICE_VENDOR := SolidRun
@@ -29,5 +27,3 @@ define Device/marvell_armada7040-db
IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
endef
TARGET_DEVICES += marvell_armada7040-db
-
-endif
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index c2ada75c2d..389082e426 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -6,8 +6,6 @@
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa9)
-
define Device/linksys
$(Device/NAND-128K)
DEVICE_VENDOR := Linksys
@@ -218,5 +216,3 @@ define Device/cznic_turris-omnia
SUPPORTED_DEVICES += armada-385-turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia
-
-endif