aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2020-12-24 11:32:47 +0100
committerDavid Bauer <mail@david-bauer.net>2021-05-26 23:10:37 +0200
commit3501db9b9b4a71ae52c539b46af817783c327866 (patch)
tree080b7990589931cbc2a212413aab1d188e040bb3 /target/linux/ramips/image/mt7621.mk
parenta46ad596a3e076599f38a4132b5d6dfee8a3102a (diff)
downloadupstream-3501db9b9b4a71ae52c539b46af817783c327866.tar.gz
upstream-3501db9b9b4a71ae52c539b46af817783c327866.tar.bz2
upstream-3501db9b9b4a71ae52c539b46af817783c327866.zip
ramips: add support for cudy WR2100
Specifications SoC: MT7621 CPU: 880 MHz Flash: 16 MiB RAM: 128 MiB WLAN: 2.4 GHz b/g/n, 5 GHz a/n/ac MT7603E / MT7615E Ethernet: 5x Gbit ports Installation There are two known options: 1) The Luci-based UI. 2) Press and hold the reset button during power up. The router will request 'recovery.bin' from a TFTP server at 192.168.1.88. Both options require a signed firmware binary. The openwrt image supplied by cudy is signed and can be used to install unsigned images. R4 & R5 need to be shorted (0-100Ω) for the UART to work. Signed-off-by: Leon M. George <leon@georgemail.eu> [remove non-required switch-port node - remove trgmii phy-mode] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 9ff066c8c3..1ae49cb96e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -240,6 +240,16 @@ define Device/cudy_wr1300
endef
TARGET_DEVICES += cudy_wr1300
+define Device/cudy_wr2100
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := WR2100
+ IMAGE_SIZE := 15872k
+ UIMAGE_NAME := R11
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += cudy_wr2100
+
define Device/dlink_dir-8xx-a1
$(Device/dsa-migration)
IMAGE_SIZE := 16000k